Red Blinking Light on USB Board

Hi, I’m trying to help my neighbor set up his CrossFire plasma cutter, and the computer is not recognizing it. I’ll hear the pleasant little windows chime when I plug in the usb cable, but it does not appear in the devices list, and it does not connect in the FireControl software. While Googling the issue, I saw that the LED light on the board that connects the USB cable is supposed to be green, but when I plug it into the computer it blinks red. I tried a different computer, and a different cable. All the same results. Does this mean the board needs to be replaced?

Make sure the FireControl driver is installed. Go to the Langmuir main page and follow instructions on how to check it. I had to use the windows 7 manual download to get my computer to recognize it. My other computers did it automatically. But the desktop would not.
Go to the pro assembly guide and go down to the instructions on how to install FireControl. Continue down to manual driver install.

Yep, I tried that. When I looked at the drivers list, nothing showed up under Other devices.

Hi, I’m having same issue and just wondered if you resolved yours? Tried fire control and Mach 3 on two different laptops and still nothing but blinking red light. Any help appreciated, thanks!

How old is the table? What version of windows do you have?

It’s the earlier model that requires Mach 3 software from what I can tell, it’s never been used though, and I have windows 10

You need to download at least three items from the Langmuir Software Downloads page. There is a section at the bottom called Legacy Mach 3 Downloads.

The three pieces you absolutely need are:
CrossFire Mach3 USB Motion Controller Plugin
CrossFire Mach3 Profile
Windows 10 Mach3 Patch

Each has their own download and installation method. Carefully follow the instructions for each.

Also, the MACH3 version MUST be 3.043, the later version has problems.


I will try again but I’m pretty positive I downloaded all of these into the c:/mach3 file as the instructions had said to, and still red blink.

Mach3 is opening, but not showing connection and red light blinking.

Then you did NOT read the instructions thoroughly.
Only ONE of the files gets downloaded to C:/mach3 directory. AND it gets ‘downloaded’ by using ‘Save Link As’.

ONE gets downloaded to to C:/mach3/plugins AND this is the required DLL to connect to the CrossFire controller board.

AND ONE doesn’t get downloaded into that directory at all. You need to download it and RUN the file so it can patch MACH3 for Windows 10.

What happens when you start Mach3?

1 Like

Tom……your words of wisdom have gotten me all the way too the mach3 screen, ready to cut. This is after I’ve downloaded Inkscape to outline, go through fusion 360 to make my design, and head for mach3 to cut. Table is only moving by manually pressing arrows or centering. I’ve loaded the crossfire Mach 3 post file into c://mach3 as I seen you had stated somewhere else aswell. But now I’m at Mach 3 screen with no luck, telling me “unknown word where unset operation could be, Block=PKII line0”
I can see your a veteran at this program, please help if you can because I am far from one! Thanks

did you post process the design in fusion? the file extension should not be .f3d, they should be .tap.

I believe this is where I’m haveing trouble. My screen in post process does not resemble the one on the tutorial video. Different pop up window, but I am able to choose the downloaded mach3 plasma program and output folder. Just when I go to open my saved work that’s what shows up.