Razorweld cut 45 will not fire when used by hand

I bought a crossfire 08/2020 with the Razorweld cut45, I have always used the cut45 on the table this past week I tried cutting by hand but the torch wouldn’t fire. I cleaned the ground clamp so it’s getting a good ground. Is there anything else I can check?

make sure you are in 2T …not 4T

I’ve tried both settings nothing works. I’m thinking maybe the switch is bad on the torch, how van I check the switch?

Check for continuity between your torch fire wires when you pull the trigger.

Will fire control or mach3 still fire the torch?

You have to unplug the plasma cutter from the CNC controller.

1 Like

if that works…DUH!

I have mach3 and it works with the crossfire, but I unplug the table from the plasma and try to use just the torch by hand it wont fire

do a trouble shooting with this suggestion. you might have set the wires up in such a way that it only works with the program…most likely a simple fix

How do you have the torch wired in for the table controller?

I checked continuity on the torch ( 2 small pins ) NOTHING, i think the trigger switch in bad. would,nt the torch be covered under the 3 year warrenty?

no idea…I know very little of the Razorweld

there is 2 plugs on the front that plugs inti the table controller. i’m trying to cut with the torch only not on the table.

I know I’m just trying to picture in my head how its wired and why it will fire with the torch command but not the trigger switch.
I would take the torch apart and check the switch and see if its making a contact when the trigger is pulled. My guess is that it isn’t since it works in the table and not by hand. Easy to confirm though by pulling it apart.

1 Like

Are you sure you have the trigger and THC unplugged from the plasma cutter?

What torch do you have?

Does the retaining cup make contact with the trigger pins?

With the torch unplugged from the plasma cutter do you have continuity on pins 3 and 6 with the trigger pulled?

If you got water in the torch then you could have corrosion in it causing it not to work.

You can call me to help with this. number is on my web site.

No the torch is not under warranty.

1 Like

@48174 @mechanic416
Listen and work with mechanic…he knows these machines…

The torch must have been dirty from using it on the table so I took apart and cleaned it now it works good.

glad to hear…guess you have now learned a lot of trouble shooting ideas for next time… or to share with other people here…