Razorweld 45 wont fire with hand torch

Been using the new razorweld 45 plasma on the table for a couple months with the machine torch. Bought the hand torch separately and went to use it today. Worked great for a dozen cuts and now it won’t establish arc and cut. I can hear the air solenoid clicking in the machine and the air works. unlugged everything, checked connections, checked ground, and retried. everything seems to work with the hand torch except no arc… anybody else had this issue?

Could be a lot of things.
Work clamp not on clean metal,
plunger jammed,
torch not seated completely in connector,
air pressure to low,

Yeah everything is brand new, air pressure good, new consumables. Took the nozzle out, inspected the electrode, put back together. Worked great, then does the same thing. Won’t initiate arc.
Wondering if it the duty cycle?

that begs the question…after how long of continuous cutting does it shut off?

30-40 inch straight cut, using drag tip and a guide.

I am guessing you are using shielded drag consumables. There is no drag tips for that plasma cutter.

30-40" should be fine as long as its not 1/2" plate.

Duty circle is only 30% at 45 amps so you can cut for 3 minutes out of 10.

1 Like