Razorweld 45 Seems to Arc, but does not Pierce

Hello All,

I am a newby to the plasma cutting/CNC world and have been 100% self taught by Youtube/Google so I apologize if this may seem like a “common sense” question to all of the veterans. I purchased a Crossfire PRO with the Razorweld 45.

I started my own personalized sign business and had successfully cut and finished 5 signs. Well today, when I went to cut my next order of signs, it seemed as if the torch would arc, but would not pierce. I had all of the exact same settings and programming as before. I took the torch apart to see if something was gummed up (even though I felt it shouldn’t be only cutting 5 signs so far) and nothing jumped out at me. So I put it all back together and tried again. I have been trouble shooting all day and still cannot get it to work. Hence, why I am here. I attached pictures to try and help. I’m hoping it is something stupid that I am doing and may be an easy fix. I am just out of ideas. I am using Sheetcam as my CAM and Fusion360 as my CAD.

I have ran my THC test and it passed. I will say, even if I generate a straight line in FireControl it has the same issue. If i manually turn the torch on, it seems to pierce for about half a second and then stops. I am open to any and all suggestions. Thank you!

are you grounding to the material or somewhere else? should be on the material.

what’s you r air pressure set to on the cutter? should be around 75-80psi.

Grounded to the material. The Razorweld gauge is reading about 62 for my PSI. Is that potentially the problem? I did not adjust the PSI since my last time cutting.

the rw45 seems to cut better when raising the psi to around 75. i’ve seen where some had situations like yours and they raised the psi and started working fine after.


Could your consumable be the problem?

Can you post pictures of your consumables?

Any chance amps was accidental turned down?

I had the same problem several times… When you put the electrode and nozzle in place do not fully tighten the retaining cap…
Leave it a little loose and it should work

There is NO reason to leave the retaining cup lose.

If you have to leave the cup lose for it to work then there is something wrong with the torch or consumables.

1 Like

@mechanic416 there maybe a problem with the torch not really sure… But I have too leave the retainer slightly loose with consumables I have bought from you and genuine hypertherm consumables. I have zero failures leaving slightly loose. Thanks for your input on the forum I have read most every post on here and find your knowledge useful.

You also know NOT to mix consumables. This can also cause trouble.

Like mechanic said, do not leave retainer lose or mix consumables. If you are leaving retainer lose to get torch to fire then 9 times out of ten the air pressure is set to low at torch, raise air pressure in 5 psi increment’s and usually will fix torch firing issues. Most torch psi is 70-75.

1 Like

I turned the PSI to 75 and it seems to be working now. Thank you everyone. I have not purchased extra consumables yet and need to. What do you recommended?

1 Like

George on here goes by @mechanic416 sells the best I have used in the rw. He sells on eBay I am sure he sells other ways also.

Glad you got it worked out; did you tighten the retainer on torch after air adjustment?

I did toghten it. I’ve cut 3 more signs since and it’s still working great👍

Thank you, I will check out his shop for sure!

1 Like