Razorweld 45 only firing for first cut then just air

I have a Razorweld 45 that I am have been using for the past few months with a Langmuir Crossfire Pro. I am having an issue where the torch will fire for the first cut in the project but then just blows air after that. Things I have already checked:


THC off, disconnected

Nozzle and electrode new

Made sure the retaining cap wasn’t too tight

Checked wiring inside of torch for loose connections

These were all done based on information on the forum.

I am using an air filter and dryer in the airline.

One thing I will mention is that the air compressor was disconnected from the plasma at first. I tried running the table 3 times before I realized this. The torch of course didn’t fire at all those three times but now I am having this issue.

Any help is appreciated.

make sure its set to 2T on the front panel of the cutter.

I forgot to mention that in the original post but yes the plasma cutter is set to 2T.


After emailing JASIC Technologies, it was determined that the air pressure is dropping after the initial firing of the torch. After a minute it will retun to normal. I can hear a relay clicking when I press the trigger even though the air pressure is almost 0. It looks like it will need to be sent to JASIC but just wondering if anybody else has had this issue and was able to solve it on their own.

have you adjusted the internal regulator closer to 80 PSI and tried it?

So may I ask what torch you have on the Razorweld 45 your using? What amps are you running at and what consumables are you using? I am not sure but I think you have to have about 50 psi to even get the torch to pilot arc. So what is the PSI at the fitting on the plasma cutter? You need 90 to 120 psi their with at least a 3/8" hose.

The torch is the J45H (X45), current set at 30A, Razorweld consumables. The psi shows 80 on the plasma cutter before initial firing. Compressor is set to 90psi.

This is the first time I have had this problem, I have been using the table since March.

First thing I would do is check all the air lines and fittings to make sure there was nothing blocking them. Next put a gauge at the rear of the plasma cutter and check it their when you try to cut… Also I would take the cover off and check the filter inside the regulator for being blocked.

There was some dirt /sand in the filter. Cleaned that out as well as checked all of the lines. Noticed that the fitting on the guage tends to leak but can be stopped by moving it a little. This definitely helped, checked it manually then ran the table. It stopped firing twice when cutting a part. I will check it more over the next two days, hopefully it’s fixed. One thing I did notice is that the guage reads about 30psi in between cuts. It goes up to around 70psi during a cut. Is it possible that the solenoid valve is getting stuck in one position?

Sounds like you have a air blockage some were. May be the filter in the plasma cutter is plugging up or a air line has the lining coming lose. There is no way it should drop to 30psi.

My RazorWeld CUT 45 had air leaks inside the case. I had to “push” the hoses connections tighter together to make the leaks go away.

1 Like