Razorweld 45 not firing

razorweld 45, wont fire, checked consumables and airflow, it has sat for a bit, any suggestion?

Check hand control, if you can fire it manually, work back from there. relay triggers go bad sometimes.

yup as drunkelbob said.

do you have the regular hand torch? if so, does it do anything when the trigger is pressed?

when mine went bad (relay) it was in the closed position, so when you turned on the plasma machine the safety system would not let it fire. be sure to unplug the trigger cord from the LS box and try the manual trigger.

It’s not firing. I hear like a puff of air. Nothing else, manually and through the cnc, same result.

whats the air pressure set to now? should be around 75 for it to even try to fire. i think it comes stock at around 60psi.

Checked that,we’re at 75. It worked last time I’ve used it. That’s been a few months. So my thoughts are what could go wrong from sitting.

Take the cap off the torch and make sure the electrode can move freely. If you push it in, it should spring back out smoothly. It could have corroded while sitting unused.

1 Like

With out air flow the torch will not fire. Button on top right set it to air test and see what air you are getting and what the gauge is saying.


When my torch is assembled should my plunger be pushed back any??? I’ve noticed that when I screw my consumables all together that my plunger is pushed back about half way.

Yes, when everything is reassembled the electrode will push up against plunger.


I haven’t checked the travel, but just wondering how much should the reassembled head move the plunger?

With consumables removed, plunger should move free in and out by finger pressure no binding or sticking. When reassembled the electrode pushes against plunger. You can’t determine travel when assembled, no adjustments to plunger…

1 Like