Razor weld 45 x45 machine torch not firing

Machine has been sitting for a month, went to cut tonight and torch blows air but doesn’t fire. When it does turn on there is a small spark and nothing but air. Cleaned it up, tried new consumables and still not working….

@kball35 Welcome to the forum.

Where is the torch holder clamped on the torch body? If it is clamped to low it can squish the torch prevent the blow back plunger inside the torch from moving properly.

The X45 sometimes has clearance issues with the consumables. After tightening up the consumable back off the retaining cap a quarter turn and try to fire the torch. If it does fire you have proved the problem to clearance issue.

Air Pressure at 75 psi + ? Amps turned up on the machine? Work(ground) Clamp on material?


I’ve read a lot of posts prior to assembling my machine (Dec 22) and made sure not to clamp the body too low, my air pressure is good, amps are up and tried loosening the retaining cap. the only question I do have is that when I tighten up the retaining cap the nozzle does not move at all (push down with the electrode). The only thing i haven’t changed is the retaining cap (which I ordered a new one from Mechanic last night). Everything worked fine when I used it last and the only thing done to it is installed the limit switch which works just fine. I had issues with my THC when I first assembled and used it with a live voltage of around 25 until Langmuir sent me a new board. I’m wondering if I may have damaged the torch by still using the machine with the live voltage. THC works fine now after replacing the board. Any help would be awesome, just wondering if it could be anything else before I pull the trigger on a new torch.

Did you check the electrode plunger to make sure it was moving freely in and out with and without the swirl ring installed? The cutting tip (you call it a nozzle) will not move when the retaining cup in installed. Buy the way I never got an order for a X45 retaining cup so you must have ordered it from someone else.

1 Like

electrode plunger is moving freely with and without swirl ring. I ordered the 8 pc 70 amp consumable kit. item ID 184678127264, i ordered it through your Ebay page, is there a different way to order?

By any chance did you hook up the hand torch to see if it fired. OK you ordered the gouging kit.

I don’t have a hand torch. So your saying I ordered the wrong kit?

Yes you did as you only have a 45 amp unit and no hand torch. I will cancel your order.

I appreciate that. Which ones will I need? I’m obviously lost here……

What should be my next step for my torch?