Razor weld 45 not powering up (solved)

(Took the outlet apart and put it back together and it works. Don’t know what I did wrong before, but it’s working. Thank you)

Brand new razorweld 45, went to power it up today and nothing is happening. It’s connected to a 50 amp double circuit breaker. I tried turning it off and on. With and without air hooked up, both the torch and the ground wires are attached to the machine. I can’t figure out why it’s not powering up at all. I tried emailing razorweld also, I just figured someone on here might have an idea what’s wrong. Thank you

Hate to ask, but I’ve seen it so many times in the hospitals I work at:

  1. Is it plugged in? :rofl:
  2. Is there power at the outlet? :laughing:
  3. Is the breaker on? :grin:
  4. Let’s disconnect the power plug, tear off the sides see if something’s disconnected inside? :nerd_face:
  5. Ok it’s “Dead On Arrival” Message the Manfacturer/supplier or bring out the Big Hammer! :crazy_face:

Seriously, any other info you can provide so we may help you troubleshoot this thing??:nerd_face:

  1. It’s plugged in
  2. Outlet has power
  3. Breaker is on
  4. Have not opened it yet
  5. Waiting on response from manufacturer