Problem installing Mach 3 USB Motion Controller

I have followed the video guide to install Mach 3 but when installing the motion controller I do not get the option to keep or discard the file however I can still drop it into my plugin files. It all works as should until I open Mach 3, it never gave me a legal notice or the option to select what controller I want to use. Then when it loads up it gives me a status that says rnr motion controller is not found and will not allow me to jog in the program without it being plugged into the plasma table. Any help would be greatly appreciated!

@Jaxon.kunkel When using the plugin with our motion card, you must have the motion card plugged into the computer in order to ‘jog’ in Mach3. If you want to ‘jog’ in Mach3 without being plugged into the table, I suggest plugging in the USB cable to the electronics enclosure and making sure power is off to the enclosure. This should allow Mach to recognize the USB card and let you ghost jog within the program.

Thank you so much mike! Working perfect now and did the whole setup process!

I am having the same trouble. It never gave me the option to select what controller i wanted to use and in the Status box on Mach 3 it says RnR Motion Card Not Found! I have tried installing without the usb connect to electronics box, with usb connected and box turned off, and with usb connected and it turned on with same problem each time. Is there something i’m overlooking?

To add to it, If I click on Mach 3 Mill or Mach 3 Plasma I get the legal notice and option to select the motion controller. When I open Mach 3 Loader I do not.

I got it working fine on my other laptop. Not sure why it won’t on the other.

This is what I’m getting now:

Hi @Islandweld,

You should be moving the file from your downloads folder to the folder where you installed Mach3, not opening it. The library files (DLL) aren’t meant to be installed by opening. I understand this is kind of confusing.

We’ve got a video to help you through the process in our Tutorials:

Check it out!



Thanks Paul, have it moving now.

1 Like

I’m having a similar problem Jaxon.kunkel was having. Everything seemed to download correctly and I followed everything step by step. When I open Mach 3 it never gave me a legal notice or the option to select what controller I want to use. Once I have the usb connected to the electronics enclosure and with the power on everything in Mach 3 seems to be working correctly but when I try to jog the X or Y axis I do not get any movement out of my stepper motors. I have tried deleting everything and re-downloading following every step and still no dice.

Hi Joe,

Sorry i missed this, were you able to get it working?

Yes I got it working my power supply in the electronics enclosure got damaged during shipping. I sent an E-mail and the guys got back to me and sent me a new one right away. Thanks guys!

Having the same problem. I can’t get jogging going. I followed the video and never got the pop-up message below shown in the video tutorial. I’ve been stuck all day trying to get something to move on the table with no luck. I pull up Mach 3 Loader on screen fine, and it says crossfire Mach 3 profile V1.1 at the bottom right. Help please.

Do you get a buzzing noise from the stepper motors when you turn power on?

Yes, a very faint high frequency buzz.

That is a good sign. Are you certain that you have dropped the motion control plugin into the plugin folder?

I am currently having this issue. I don’t get the option to download the usb motion controller but brings up that inproper app association. I contacted support and they sent me a link to download or right click and save to the plug in folder. I did so, I did not OPEN the link but right clicked save as and sent it directly to the plug in folder. All I get is no RnR controller found on the mach 3 screen bottom left. This is the only thing holding me up at this point. Im not very techy so I need some better assistance than to just watch another video ive already seen.

You need to be plugged into the controller (the USB connection). Turn the Crossfire control box on before firing up Mach.

I’m having this issue. I’ve done everything and still nothing.

How old is your machine…?
Mach3 is only used in the older generation Crossfire.
Anything purchased from Langmuir in the last year uses FireControl…free with the Crossfire.

1 Like