Primeweld machine torch

Okay team I am stumped!
Equipment I am running, crossfire pro and second gen Primeweld cut 60. I have had no issues to date and I am running using the cnc port divided voltage, (I know risky) Here is where the issue comes in, I cant get the machine torch to work. I bought a used machine torch (primeweld) and it worked but not good went through consumables super fast so went back to and torch. Then bought the new Primeweld coax machine torch and it wont work. Fire control runs just like the system is working I see live voltage the air comes on and the table runs through the program with no errors the torch just never fires.

It must be something simple WHAT AM I MISSING

welcome back @DaveP

I think I will summon the wisdom of @mechanic416 ,George, for some information on this…

Noses of bats…tails of donkeys…and blood from small bugs…!!!I SUMMON THE GREAT GEORGE!!!

1 Like

If the hand torch works from the CNC port then most likely the swirl ring is missing or air pressure to low for the machine torch 60psi min flow.

1 Like

Thanks a bunch George you are still the guru! Bumped the air up from 55 to 65 and the machine torch worked flawless!! Who new a few psi could make all the difference.
I could not find anything that told me to run an extra 5 psi for the machine torch that would have been some key info up front.

Thanks again George!


1 Like