Primeweld Cut60 won't fire for 2nd cut

Please help a newbie :slight_smile: I’ve had my Crossfire Pro for about a month now and was using a cheap amazon cutter called arcfony but I kept having issues with it frequently failing to fire the arc after a few minutes. I assumed it’s duty cycle was being reached quickly so I decided up upgrade to a primeweld cut60 since it claims 100% duty cycle at 40amps or less. Got my machine yesterday and I just got the cnc port wired up today and tried it out. It will fire the arc for the first cut just fine, but then when it tries to do cut# 2 it will not arc. The post air runs for a few seconds after the cut. If the crossfire tells it to fire while the air is still running on post flow it will not arc, but if I try again as soon as the post air is done it will arc again?! Anyone know what’s going on and what I need to do to fix it so it will arc again cut after cut?
my cnc port is wired to the 50 to 1 voltage for the THC (4&6) and my firing wires are on 1&2. My old cutter was wired for raw voltage if that helps. My old cutter I had the pierce delay at .7s and it would work consistently. The cut60 though I tried to bump up to 1.1s and was still not consistent.

Sounds like an air pressure issue. What pressure do you have when the air is flowing?

It could be the air solenoid, but I doubt that on a new machine.


As @ds690 said what is your air pressure at the machine?

I find for thin metal I run 0.6 Pierce delay works perfect for my cut60.

1 Like

I have a Cut60, as do many others on this site, and we are using successfully using them with LS equipment. I second the opinion that your air pressure is dropping to low. How much pressure do you have at the cutter? What size compressor tank, line size (smallest restriction point), air drying method, etc. Basically give us details on your air equipment.

I regularly use .6 or .7 second pierce on 16-18 gauge material at around 40 amps.


Air pressure is set at 55psi at the cut60

I have a large compressor that is able to supply constant pressure and had no issues with it keeping up to the demand when using the old cutter for 30-45 min projects straight. This issue occurred starting at cut #2.

Try pushing that to 65psi.

1 Like

I run a CUT60 for over 20 minutes at a time, with a small air compressor all without issue.

So if you have good air, it must be something else in-between.

Let’s talk about your filtering and whatnot because 55psi should still fire your plasma cutter without issue.

You don’t have more than one regulator in place right? Some people like myself set the air compressor up to 120psi, and set the plasma cutter’s air pressure with SET engaged.

If you’re using a machine torch, it’s well known around here that you want to run about 10psi higher than you normally would at your machine.

I’m running 120psi at the compressor and letting the machine regulate it. I have two desiccant traps in the line for filtration.

Do you have a filter after your bead cell dryer? Beads can make it out of them and restrict your air volume you may have pressure but not volume.

Silly question because it sounds like you know how things work but sometimes mistakes are made; can you post a screenshot of your post process for the program you created? Maybe just double checking to see that you didn’t click in the wrong place and fat-fingered a number anywhere?

I used to cut 16 gauge at 55psi, and moved up to 60psi and more for 12 gauge and thicker.

What thickness are you cutting?

when you say 55 psi, is that on the dial on the front or after you press the set air switch? the dial is off by 5-10 psi so you actually have to set it higher on the dial and press the set air switch to verify what the actual working psi will be at.

if you’re setting the dial to 55 psi then the working psi is actually lower and can cause issues like yours.

1 Like

Just turn the pressure up to 70 or so and let us know if it works.


Soooooo, Yeah. For everyone saying it’s your air, it’s your air :wink: … Yup. I was setting the dial to 55 without the air switch ON. As soon as I adjusted it to 55 WORKING psi with the set air switch on she runs like a champ! Thanks everyone!!


Yes I know my water is dirty. I need to build one of those cool drainage systems I’ve been seeing.

1 Like

Yeah if you re-read, I said with SET engaged.

Glad you got it!

1 Like

Yeah, but that requires me to actually READ :wink:

1 Like



Any chance you could tell me how you wired the arcfony? I have the Thc but havemt figured out how to wire it up.


Welcome to the forum.

I am not familiar with your cutter but, perhaps, after looking at several of these wiring examples you can look at your schematics to figure it out.

Remember the red wire goes to the work lead (+) and black to the torch (-).

1 Like