Primeweld Cut 60 Firing Anomaly

Hello, another plasma novice here and I have exhausted my own diagnostic powers supplemented with other forum posts on Cut60 miss-firing. I hope you guys can help.

I am setting up my CrossFire with a Cut60 machine and have an odd situation that doesn’t quite fit other reports of firing anomalies.

My test pattern is 8 slots, 1/3" wide and 3" long in 1/4" mild steel. The first slot always cuts perfectly with a good quality finish. The second slot never cuts as the torch does not fire. Very occasionally the torch starts cutting on the later slots but only until the end of that slot and then won’t fire again on the next slot.

System Details

  • Cut60 is connected to a dedicated 240V/32A power supply
  • Tecmo PTM-60 machine torch with new consumables
  • Primeweld hand torch behaves exactly the same as PTM-60
  • Swirl ring is installed correctly
  • Simple torch fixed Z height 1/16" above the work (No THC)
  • Air is refrigerated dry at 2C dew point at 65 psi. 16 CFM
  • Cutting current 45A
  • Switch set at 2T
  • 0.7s pierce delay
  • 10 s post flow delay
  • 47 IPM cut speed
  • Workpiece lead connected directly via freshly cleaned and bright area
  • FireControl 21.1.5 for PC


  • Firecontrol software and hardware appear to be behaving correctly
  • Resistance check across pins 1&2 of CNC port show correct behavior at all times on all slots even when the torch is not firing (zero resistance when torch should fire and high resistance when it should be off)
  • XY motion is always fine
  • If I manually insert at least a 5s pause in the GCODE between cuts, all the slots cut fine with good quality.

Now I could fix this by simply inserting a 5s delay between each cut in the toolpath. But I feel uncomfortable doing this as I don’t understand the cause of the problem so never 100% sure it won’t re-appear under different conditions.

Ideas very welcome.



Try lowing cut height a tiny bit more and go 70psi.

1 Like

whats the psi input into the cutter?

also, have you tried to up the pierce delay to .8 or higher? you should be closer to 1 sec delay for 1/4 inch material.

1 Like

Thanks, I have tried varying both but not together so I will give that a go in the morning.

Input pressure is 90 psi. Pressure is maintained at constant 65 psi at the torch over long periods when the 2T4T switch is set to air flow function. I have monitored during cutting as well and it regulates well at the set point of 65 psi.

I have trialled different pierce delays with no change just extra dross at times above 0.7s.

I should also say that on the second slot, the air doesn’t start so the blow-back sequence doesn’t begin and may be why the arc doesn’t initiate so pierce time not having any effect. All I can say is the CNC electrical start signal to the Cut 60 seems correct but the air/blow-back/arc initiation doesn’t happen.

Unless I leave a 5 second pause between cuts.

This won’t help resolve your issue, but I would bump this up to 30 seconds.

What type of compressor are you running? What is your CFM for your compressor?
How much storage do you have?
What size are your lines feeding your compressor?

1 Like

Hi 72Pony,

Will increasing post flow have any effect? Without a pause between cuts how will post flow influence the next cut if cut starts immediately after the move to the next slot?

I’m running a 14cfm compressor with a 90 L=24gallon reservoir. It is about 100’ away from the refrigerated air dryer which is the 5’ away from the Cut 60. A 1/2” bore pipe system connects the system.

I wondered about remoteness of reservoir but wouldn’t the air still start and attempt a blow-back even if the air supply was weak?



if you hook up the hand torch and press the trigger a few times, does it always fire or is it intermittent too?

1 Like

As I said above increasing the post flow won’t resolve your current issue. But it will help you extend your consumable life.

1 Like

The air compressor is to small to be that far from the plasma cutter. Buy putting a pause between each cut it has time to not only build pressure but volume to fire the torch.


This sounds like a air solenoid problem. It seems like the solenoid is not closing quickly enough to restart the Torch during the post flow.

On the initial start, the solenoid just has to open to fire the torch. On subsequent cuts, it has to quickly close and then open again to blow back the electrode. The piston in the solenoid could be sticking and/or not completely closing off the air flow.

You should probably contact Primeweld.


Always fires with the manual torch. But it always fires reliably via FireControl as well using the manual torch fire command there too

So, is it working normally with the hand torch or is it not? These two statements seem to contradict one another?

If it is only doing this with the machine torch perhaps you have your machine torch mounted to low and the clamping force is keeping it from springing back properly?

Yes, that’s a good point and one I had wondered about. But if air volume delivery was a problem then long single cuts would suffer - but they don’t seem to. Just stop-start cycles.

Unless blow-back requires a higher capacity for the initial start? Guess I could buy an air reservoir to situate close to the plasma cutter.

I was convinced it was a moist air problem and invested $800 on a refrigerated dryer but it had no effect whatsoever.

I really appreciate all the comments, as I’m struggling to self-diagnose this being my first step into plasma cutting, let alone cnc plasma.

Sorry for the ambiguity - using the hand torch it appears to respond 100% correctly to a trigger pull. But the same torch triggered by the cnc port fails on the second slot.

The machine torch not having a trigger can only be controlled by the software. In this case it appears to respond correctly to the software manual torch firing but does not respond to sequential fire commands in GCODE if the pause between is less than 5s.

Excellent point about the torch holding - this was the only suggestion from Primeweld Support when I asked them. Truth is the Langmuir machine torch holder does hold the torch way too low. But I corrected that by moving the torch and slackening off the bottom bracket - but no luck there either!

This sounds very plausible. Off all the things I have thought of and seen suggested this seems to match the symptoms the best

1 Like

I have found that most machine torch’s will need 5 to 10 psi more then a hand torch to fire.

1 Like

Yes that could also be causing it. I never liked the solenoid setup of the Primeweld.


Did you run this by Primeweld?