Primeweld cut 60 fires then stops

Need some help! I was running a hynade plasma cutter and just bought a primeweld cut 60. Got everything hooked up. Went to do a test cut on 1/4 and torch fires and then shuts off. I will attach a video and picture with information. I have 60 psi, 45amps on 220 outlet. Pierce delay was 1.2. Wired up cnc port, the wire that goes to the VIM control box (for THC) red goes to 4 & black goes to 6. The wires from the divided voltage pigtal is wired to pins 1 and 2. Was told it didnt matter which color wire went to which pins on 1 and 2. I tried swapping the VIM plugs and it is not changing. Im new to understanding how this stuff works. Also im running the regular crossfire with firecontrol.

Are you using machine torch or hand torch?

I was told by primeweld that the machine torch likes more air to fire like 75psi.

Try the search feature too right corner for this same issue. It’s probably been cover before since the cut60 is widely used on this forum

1 Like

Also 1/4” shouldn’t need 1.2 second Pierce delay try like 0.7 and see if that works

1 Like

Pierce delay .7, increase air to 70-75.
Please send us a picture of your torch mounted in the machine. Pin 1 and 2 are the torch on /off. Divided voltage pins 4 and 6. According to your post its, wired wrong??
#4 is the red wire
#6 is the black wire


So, you posted this on the FB group (came up on my feed at the same time).

Don’t think anyone’s asked by what you meant “tried swapping the VIM plugs”

What does this mean exactly?

There is no swapping out of anything, you either run DIVIDED or not. And your torch ON/OFF pins don’t matter as you acknowledged.


Im using hand torch.
I will try to increase air pressure, and decrease pierce delay.
I the red and black wires that go to the black box for thc is what i tried swapping to see if it changed anything. The divided wires goes to a single plug that plugs into the computer control box. I was told the red wire goes to pin 4 and the black wire goes to pin 6. I swapped the wires on the control box to see if it made a difference and it did not change anything.
I did read down through a good bit of the posts and didnt find my problem.

Ok this still doesn’t make sense what you are saying.

The “black and red” CATIII leads that connect to the FACE of the VIM, are for RAW voltage only. You would only be able to use those if you opened up your plasma cutter and wired them directly to the lugs of your machine. Seeing as how you made no mention of this, you’re only option really is to use DIVIDED voltage as you utilized the correct pins 4 & 6.

1 Like

have you done the THC test like a few others have suggested on the FB group?

technically, the divided voltage cable does have a red and black wire on the end but yeah he doesn’t mention which cable he’s using.

His first post states pin 4 & 6 via the CNC port

That means there’s only one cable he can use, and that is the barrel plug with a red and black cable (shown here on the left side of the picture)

He cannot utilize any other cable unless he specifically wired up for RAW directly to his machine’s lugs and uses the CATIII cables supplied to connect to the face of the VIM’s ports

Made absolutely no mention of wiring it up any differently so I again get confused what he means by switching cables

We’re here to help but there seems to be a language barrier or something


It’s really not clear how he has this wired to and from the VIM. He sounds like he has the divided voltage wires hooked correctly to pins 4 & 6, but no mention of where that is plugged in to the VIM or if there is a cable going from DIV output to the THC port on the electronics enclosure.

He also keeps referring to pins 1&2 as “divided voltage”, when they are the torch on/off pins. He must be using the wrong terminology, since it wouldn’t fire if this were hooked up wrong.

His issue could be from not hooking up the wires correctly to the VIM and not reading any voltage in Firecontrol(easy to check) or too long of a pierce delay causing the torch to flame out before it starts moving.

1 Like

Tag you guy’s are it. It sounds like he has the raw voltage cable hooked to the 50:1 pins 4 & 6 then plugged into the raw voltage ports on the VMI.

I have these wires wired to pins 4 and 6. Red wire to pin 4 and black to pin 6.

I have these wired to pins 1 and 2.

No, Those are for a raw voltage setup. You should have an additional cable with a barrel connector on the end.
Red to the 4 and black to 6
It will plug into the end of the VMI box labeled divided input.


Like @Bigdaddy2166 mentioned and I mentioned earlier

Those CATIII cables are for raw voltage

You skipped reading the manual for Langmuir when you wired up your setup! I posted a picture of the instruction if you scroll up.

1 Like

I don’t believe the 50:1 divided voltage damaged the VMI box. Divided voltage is a much lower signal voltage 1/ 50th of the live output of the plasma cutter. That has been adopted for plasma CNC.

To be perfectly honest i didnt go back to read the instructions. I had these all hooked up to my hynade plasma cutter and it was working as it should. When i saw the pictures of the 4 wires going to the cnc port pins i assumed they were the same 4 wires. Im going to have to see where this other barrel connector is.

1 Like

Fortunately you can buy those cables on Amazon even.

Now, I could be going against the grain here but my advice would be to just wire it up for RAW directly to your machine.

I ran DIVIDED for 10 months straight without issue, then bam…killed the circuit in my VIM on the DIVIDED side.

I switched to RAW and it’s been perfect ever since. My theory is that this is probably why Arcdroid even removed PrimeWeld from their supported list as they only deal in DIVIDED voltage.


I agree raw voltage is the way to go. But that is your call. It will work either way.

1 Like