Post processor trouble

hey i saw an old topic about this but figured itd be better to start a new one.

when i go to upload dxf files i made from 360 to firecontrol to burn its telling me im using the post processor for the mach three and to download the fusion one for firecontrol.

i have the z axis/thc upgrade so i picked that one tried to open it and it takes me to and wants me to download something from their lists. after i downloaded and didnt open again i went to 360 and tried to resetup one of my programs to see and langmuir is in it now. chose it so entirely redid setup and it still doesnt show on firecontrol. any advice on what im doing wrong?

you don’t open it after you download it, you copy it into a folder within the fusion360 folder. should be instructions somewhere in the support section.

Did you manage to install your post processor into Fusion 360?

1 Like

go to FIRECONTROL WITH Z-AXIS, then section A4 and follow those instructions.

1 Like

Post a few first lines of your G-Code.

from 360 or firecontrol?

i got the post processor bit sorted out but itll be later in the day before i can hook up and check it

but thanks for both your help.

It’s going to be the same g code whether you take the original posted file from Fusion 360 or resave it and post that file from fire control.

If we’re talking about the NC file.

didnt know nc file held gcode my bad

( vendor: Autodesk)
( description: Generic Cutting Machine)
G90 G94

(2D Profile1)
G0 X-1.4074 Y-0.3057
G92 Z0.
G38.2 Z-5. F100.
G38.4 Z0.5 F20.
G92 Z0.
G0 Z0.04 (IHS Springback + Backlash)
G92 Z0.
G0 Z0.15 (Pierce Height)
G4 P0.5
G0 Z0.063 (Cut Height)
G1 X-1.2625 Y-0.439 F40.
G3 X-1.5375 Y0.439 I-0.1375 J0.439 F40.
G3 X-1.2625 Y-0.439 I0.1375 J-0.439
G1 X-1.2195 Y-0.2469
G0 Z1.

Yes,The NC file is the g code.

I always assumed it stood for numeric control but I’m not sure.

I would walk back through the steps of installing your post processor.

1 Like

just started making headway into doing it for all my programs thanks again

one more question, since the fireshare programs didnt show will i need to do a setup for them as well?

A cut ready file should be able to run in fire control when you download it there’s an option to modify the IPM and some other variables.

The files that are not cut ready you’d need to download the SVG or DXF or whatever kind of design file is included and then bring it into your CAM software either Fusion 360 or fire control

1 Like

I just finished my first test program on Fusion 360 and ran into the same issue your having. The FireControl brought up this error message; “This program appears to be incorrectly generated using a Post Processor for Mach3” I went to Langmuir web and downloaded another post processor per their instructions, reposted the part to be cut and got the same error message. I double checked the post processer on Fusion and it confirmed the change to Version: 43757 and the date and time. Still no good and waiting to hear back from Langmuir.
Did you find what the issue was and can you share?

1 Like

I’ve also heard but not checked it out that Autodesk put langmuir on their post processor list so if you scroll down to it it’s probably there.

Just checked it out yesterday and can confirm it’s in the new update. :+1:

1 Like


Thanks that helps alot

1 Like