Post process isaue

Yes I put in the correct post processor , I see this is a common ordeal just many ways to fix depending on details… so hopefully someone can help me narrow it down by tmrw . Thanks in advance

Could you post the first 20 lines that g code that caused the fire control to throw the error?

1 Like

Fusion 360 or SheetCAM?

Fusion 360

Yes sir , give me a bit , not home at the moment

When you go to post process, does you windows look like this? (Please ignore my Fire Control Plasma v1.7. I’ve modified it slightly. The correct one from should read Fire Control Plasma v1.6)

1 Like

Mine says 1.6 but that’s all they had … I thought maybe it was a mixup at Langmuir cause the firecontrol for my XR and the ones without THC and blah blah was both 1.6 which I thought was weird … so is this 1.6 wrong ?

Uploading: IMG_0311.jpeg…

No. v1.6 is the correct post processor.

1 Like

Something is wrong with your G-Code. It should start similar to this…

G90 G94

(2D Profile1)
G0 X0.7419 Y0.632
G92 Z0.
G38.2 Z-5. F100.
G38.4 Z0.5 F20.
G92 Z0.
G0 Z0. (IHS Springback + Backlash)
G92 Z0.
G0 Z0.15 (Pierce Height)
G4 P0.9
G0 Z0.062 (Cut Height)

Can you take a screen shot of your Post processing window? Or, like Tin said, export your Fusion file so we can take a look.

Everything I’m seeing looks correct in your post window. It’s possible (however unlikely) that your post processor is corrupted. You might try re-downloading from the link above and re-installing the post.

Otherwise, we’re guessing until we can see the Fusion file. There are a couple of posts on here that walk thru the Export process. (File → Export → choose .f3d → select a location on your computer.) You may have to rename the file to allow it to be uploaded here. (Or zip it.)


It was a nightmare trying to find the fusion file from within firecontrol . I saw it on the plasma computer files but when tried to find from fire control to run a cut … wasn’t there .

I’ll try n locate it to send

While I’m trying to find the file … when I went to get the cut out of 360 it showed that firecontrol wasn’t in the post box but is in the library … could this be the issue ?

Entirely possible. Click on the folder next to the blank “Post”. It should bring up your library and allow you to choose the FireControl v1.6 post processor. FYI - The library in Fusion is a collection of all the posts that you have access to, not necessarily the post chosen.

1 Like

Think I’ve got it figured … for whatever reason I had to re-save with it corrected in the post process box cause now looks like g-code is correct… I hope anyway


You’re code looks good. I’d dry run to make aure, ut i think you’re out of the weeds.

Just tried it and it said the same thing… I’m using mach 3 … so what now ? Gotta re download the post processor and start all over ? And I can’t find anything in firecontrol that’s on the computer it’self except what’s been downloaded a while back… I’ve gotta copy and paste it into firecontrol… could that be the issue that the firecontrol is bad ? I sure appreciate ya help cause I’m at Witts end here