Path generation

im I doing something wrong … I get the generating path window but it never moves or turns green

Restart mach. If that doesn’t work restart the computer.

1 Like

Are you clicking on the play button at the bottom of the screen? It’s the triangle in the middle of the screen at the bottom

I am having the same issue. When I run the “Load G-Code” it pops up the window Path Generation and never moves. The code window shows all of the codes lines but does not show the object in the upper RH window that it is supposed to be cutting out. I have rebooted the program several time and restarted the computer almost as many. Any help would be greatly appreciated.

Did you hit the red Reset button?

Any chance you can take a screenshot of what you’re seeing & upload it in your reply?

Thank you James, sometimes it’s the most simple things. That worked. I appreciate your help

1 Like

I get a “Path Generation” window pop up when I try and load a new g-code file It says “Please wait…Generating Path…” but never goes anywhere. The G-code loads but never get a tool path to run. I had the demo but bought the full version as soon as I found I couldn’t design anything usable under 500 lines. Reset button does nothing but dings.
Solution: Found Mach 3 has to have the CrossFire plugged in and on to generate the path.


can anyone tell me how to create the tool path so mach3 will load it with G code

There is a video on how to do that. It takes a few steps so it’s good to watch at least once.

There are a couple of posts here in the forum with step-by-step pictures (I did one or two) that you can find using search.

You need to change to Manufacture from Design, create a setup and then create the toolpaths. Then after the G-Code is generated you’ll set the pierce delay and save it for use by Mach3.

So I’m currently having the issue of freezing on path generating. I’ve restarted the computer and still having this issue. I even plugged it into the Langmuir table to see if that could help with loading the tool path. Ideas? Thanks!
Can you see the photo below?

Quickest solution is to break it into a couple or three paths.

I define one path for small internal cuts that can’t support lead-ins. Another for just line cuts. One for larger cutouts with proper lead-ins and a final one for the outside perimeter cut.

Also there’s another post that says there’s an issue Fusion is working on. Splitting the paths works fine though. When you generate, make sure you’ve got the setup selected & not just one of the paths.

So now all of the files I save would have to be broken into three different files just to cut them out? That would take a long time to split everything into multiple files. Especially when they have worked before. There has got to be a easier way.

So to solve my problem, I closed Mach 3, plugged in my laptop to the Langmuir CNC controller, turned on the Langmuir system, then started up Mach 3 again. Now it loads the file in the top right corner. Magic

1 Like

Ah, didn’t realize it was Mach that was freezing on you. When you said it was generating the path I figured you were in CAM. Since there’s not a lot of stuff happening when Mach calculates the motion file, it’s almost always a problem with connectivity issues if it hangs. Restarting everything generally solves it as you found. Same thing will happen if you turn off the Crossfire or you dislodge the USB.

Glad you got it working :+1:

Yea for sure! There are a lot of steps in these processes. Thanks for the input.