Outline of a pine tree in .SVG (Need a little help) ***Solved***

Ok gang, not sure if I’m going to word all of this correctly but, I’ll give it a shot.

I’ve taken the outline of a pine tree in Inkscape and converted it into an .SVG file there. I then insert that into my drawing in the model workspace of F360. I size it there and position it on the part where I’d like it and “slap 'er down”…

When I make it around to CAM/Manufacture to create the toolpaths using “centered” and all for my offset, it still wants to select each curve on the tree instead of the entire tree outline in one shot. Make sense? I know I’m missing something somewhere…

Bend lines haven’t been a problem for me but, these curves seem to be causing me a small fit!! LOL

BTW, what is the correct format for the .SGV file upon saving in Inkscape??(Plain? Inkscape SVG? Optimised?)… Never figured that one out yet…

This is what I’m trying to accomplish…
image

And, this is what I’m up against in CAM…
image

Been working at this one for a good day or two… Thanks for any help!!

Alright… Looks like according to what I’ve read, using “Plain SVG” is the way to go…

Correct. That’s the “standard” SVG. The other formats (like “Inkscape SVG”) don’t necessarily match the standard definition so a different app won’t necessarily read it the same as Inkscape does.

That being said… I actually tried all the available SVG formats and end up with the same issue… A different reason probably…

Thanks for helping clear the format thing though… :wink:

It looks in the picture as if the lines aren’t joined. Did you zoom way in to see if they’re all connected?

That sometimes happens when inserting into Fusion. There’s an add-in that will fix them but I’m at work so can’t remember what it’s called (there’s a post here somewhere about it). You pick the part and select the fix add-in and it joins line ends that are within the tolerance (like 0.1mm) you set.

If you want to upload the SVG I can look at it tonight when I get home.

Yeah, I tried the “Fill Gaps” add-in on the top section of the tree for comparison and it still wanted to do the same…Just little sections of the outline…

I’ve attached the SVG I’ve been inserting into my sketch…

svg

Seems like once I insert the tree, I do get a complete outline… Then, I’ve been deleting the couple of lines at the base of the trunk in order to leave the majority of the tree body inside the cutout once it’s cut on the table… Make sense? I’m just going for a single pass on 99.9% of the tree…

Solved!!!

So, as it turns out, this was something I was missing. Pays to know your software and this was just another instance of the kinds of things I’m continuously learning as I go through the process of getting up to speed with all the CNC and design packages…

So, I had these lines in the tree image(SVG) I was using that wouldn’t select as a whole in order to establish tool paths for cutting. They always wanted to highlight as short and individual curves along the edge of the tree.(See picture above) I found out if you have an open contour like that you need to click on the part of the curve that highlights on one end of the tree outline twice and you get an option to choose “closed contour / open contour”.
image
Choose “Open Contour” and and then the other end of the open contour and the entire thing will highlight as one continuous line… Instead of what I was getting as shown at the top of this post.

Never had this issue with straight “bend lines” because they were made of just one line…

Not sure if this is the right way to go about this but, it did work for me…

The result…

BTW…the splatter/dross you see came off with a finger nail… Everlast 50s…43A…1.1mm…120 IPM…75PSI…16g steel…

1 Like