Odd Hypertherm 65 behavior

The oddness is that my hypertherm 65 decides to not fire. This has happened twice now so I thought I’d ask if anybody else has seen something similar.

The first time it was after I had shut down after doing some normal cutting, everything had gone fine and I powered everything down, then come back a few days later and fired everything up, but no fire from the plasma, but all axis moving fine. I could hear the relay click but no fire. I cycled power on everything, same behavior. Then I powered down the hypertherm and swapped to the manual torch, which fired fine, so power down again & reconnect CPC & machine torch, and no fire. Next I powered down the plasma and pulled the CPC cable and hooked an ohm-meter on the torch pins and sure enough they were closing when I did the manual torch fire. So I scratched my head a bit with the plasma still powered off, then connected everything back up and it was operational again!

The second time was yesterday. I was cutting some brackets for a buddy and had to swap in a new piece of sheet metal. I forgot to connect the ground & had to hit the stop button on the laptop when I noticed only a pilot going. I connected the ground and restarted but no torch fire again. Once more I could hear the relay click when I did the manual torch fire in the software. So I power cycled the plasma and the crossfire control box & disconnected the USB. When everything came back up I tried again, still no fire. So power down the plasma & swap to manual torch which worked again, but swap back to machine torch and no fire. I eventually turned everything off and let it sit powered off for 10 minutes, then power everything on and I had fire once more, it worked to cut another 5 brackets no problems after that.

Anybody see anything similar or have any thoughts?

Thanks,
Jeff