No Voltage Detected (solved, new torch required)

Hello, I am trying to cut out a sign on 1/8th material. When I press start for it to begin the cut it goes to it and the torch just goes up a bit and blows air then says cutting voltage not detected. I was looking at the live voltage it goes to about 2.6v then just drops back down to zero. It has been about 3-4 since I last made a cut. I changed consumables made sure I am getting good ground to the material I am cutting and I keep getting the same result. Any help is appreciated thank you.

I am using Fusion 360
Feedrates 70 in/min
smoothing .001
lead-in radius 0
lead-in sweep angle 90 deg
lead-in distance .019

cut height .05
ihs springback .02 in
pierce delay 1 sec
pierce height .13
retract height 1.25

Check your air pressure. Make sure the electrode isn’t stuck and can be pushed in and spring back out.

This is not a settings issue. It’s a plasma cutter issue.

The air pressure is usually what I have it at. Its at 100 psi. I checked the electrode to see if it was stuck but I was able to push it in and it springed back out.

What plasma cutter are you using?

Do you have a machine torch or hand torch? If hand torch can you get it to fire and cut pulling the trigger?

Can you post a video or post some pics of your setup?

I am using the crossfire xr

Shoot I had seen your previous posts back in August where you said that… Sorry totally forgot.

What plasma cutter are you using. I think I have asked before; haven’t seen you ever answer that question.

Have you been making successful cuts since you had the electrode issues back in august?

No worries. I am using Razorweld cut 45. Yeah it has been working fine. But it has been about a month since I last did a cut. We recently had a power outtage could that have maybe messed with the voltage?

Not very likely… especially if you weren’t operating it while it happened.

You don’t happen to have the torch clamped around the torch head, do you?


I just moved the clamps. Same result it did go lower but it just blows air and says no cutting voltage detected. The live voltage goes from 0 to like 2.6 then it just says no voltage detected.

If you had it clamped to the torch head it’s possible you damaged it. What is the regulator on your machine set at? You might try turning it up to 75 if it is set lower. You will have to pull the case off to get to the regulator inside.

If that doesn’t work you might call razorweld and see about getting a replacement torch.

1 Like

The 3 main causes of no pilot arc are air pressure, electrode plunger and cup pins.

You need to check the electrode plunger that it is free and moving in and out.

Then check the cup pins to make sure they are not corroded and freely moving in and out.


The psi on the machine is reading 80 psi

I see you already checked the plunger… check the cup pins as @mechanic416 suggested…

Also when the air comes on to fire the torch how much does the pressure drop? If it is set at 80psi I would expect it to drop to 75 when cutting which is where you want to be. If it is dropping down lower…like into the 50s you may have a bad regulator causing the problem.

1 Like

What are the cup pins?

toolboyCrossFire PRO

Nov '20

Machine torch or hand held?

Chech the spring loaded pins that touch the cup

I had problems with these pins in the past


If you click on Nov’20 in the linked post from @toolboy above it will give you more info on checking and cleaning the cup pins. Let me know how it goes.

You can also search cup pins by clicking on the magnifying glass in the upper right corner.

1 Like

Do the pins look clean? Kinda hard to tell in the pic. Do they seem to move in and out easily?

Did you get a chance to check the pressure drop when the air comes on to fire the torch?

1 Like

@Chriss Where at you at currently with your issues?