No program speed found

Hi,

So I have downloaded a few dxf files online including the world map. when importing the file into fire control I keep getting the ‘No program speed found’ error. I double check to make sure the tool speed input and machine speed are the same in sheetcam. Also made sure I’m using the fire control post processor. As I’m in Australia I use metric but have also tried inches but no good. It just seems to be not working with some of the dxf files I have downloaded and not others. For example the cow and the bikini files from fireshare work ok but not the world map. It also works fine with the dxf files I have made myself. I’m sure its something simple but cant think of what.

Any help would be greatly appreciated.

Thanks, Jake.

I’d suggest attaching the file to your post. You should be able to just drag and drop the file into the reply window, or click on the up arrow icon in the reply window to attach a file. Without the file it’s hard to know what is wrong. Attach the gcode file produced by Sheetcam.

I had the same issues when I tried to use mach 3 control software. I got in touch with Langmuir and they notified me I have to use FIRE CONTROL to run a crossfire PRO not MACH 3 . Mach 3 is only for the crossfire .

When you import the DXF into Sheetcam what are you specifying for the scaling factor? In this pop-up:
image

What may be happening is that it’s scaling inappropriately so not all of it is getting into the Sheetcam workspace. DXF files don’t always maintain their native units (mm vs imperial inches) so you may need to play with scaling at 1:1 or 1:25.4

Most of the Fireshare files are probably in inches since most of the Crossfire users have been from the U.S.

I am having the same issues with some of my files. Did you figure out the issue?

Thanks

I am having the same problem… Crossfire pro with fire control V1.2ls and height control LS-THC (V1.10). This same error message ( No program speed found) appears on some fireshare files but others and also with my own files written with Inkscape. double checked scaling w/o relief.

The PS value gets inserted by the post processor. Make sure that you are using the correct post processor for whatever CAM software you are using.

1 Like

I am using Firecontrol-V1.6 in Sheetcam

Be sure to check if you are using FireControl posted files when downloading from FireShare. Mach3 programs will sometimes fail in this way. You can also check the last line of the program and look for a PS comment that looks like: (PS100). This is added in every file post processed by our posts.

If you are still having problems, please post the program you are trying to cut and where you found it.

1 Like