New CrossFire, No Connections in FireControl- Solved

Windows 10, FireControl 20.4 installed.
MacOS, FireControl 20.4 installed.

Drivers on both systems look good, and on Windows RNR ECO Motion 2.0 driver is installed and working correctly (and disappears when supplied USB cable is unplugged).

FireControl starts up on both OS’s, but neither is able to see the Crossfire. “No Connections” is all that shows up in the top right.

USB cable is plugged in before starting Firecontrol on either OS, and both OSs appears to be happy with the device.

I would greatly appreciate any tips. Thanks.

1 Like

My bad.

I incorrectly assumed Firecontrol worked with the Crossfire. I have Mach up and running and all motion control is working as expected.


I am experiencing the exact same issue. I have tried this on 2 seperate systems and both have the same problem.

Both are running windows 10 and I am able to see the driver does install. Prior to seeing this thread, I thought Mach3 was having problems too, however, it is working as expected.

I am new to all of this and want to get my system working so I can learn all of this. It really looks like a lot of fun.

I’m confused by this statement. Mach 3 is the ONLY software that will work with Crossfire. You need CrossFire Pro to work with FireControl.

Fair enough. I misread the the 2nd topic, it was early AM.

but thank you for the clarification that only Mach3 works with this system. I was thinking that FireControl worked as well. It is good to know I am not going crazy.

Not yet anyway. Stick around, we’ll see what we can do about that…


I think the new crossfires are being shipped with firecontrol electronics. On the crossfire store page there is no more mach 3 mentions. Only firecontrol

1 Like

Whoa! Talk about sneaking in the backdoor! Sure enough, on the “What’s included” section of the Crossfire page is:
" FireControl CNC Control Software - developed by Langmuir Systems specifically for the CrossFire line of CNC Plasma Machines."

Interesting that FireControl is included, but a controller update (other than implied by FireControl SW support) is not (or features like Z axis and THC.

UPDATE: Sorry, I didn’t read far enough (too overwhelmed, I guess). The next line says:
“Upgradeable CrossFire Gen2 Electronics (Z-Axis, IHS, and ATHC upgrades coming soon!).”


Sneaky indeed lol, I have been keeping an eye on the store page daily for the past two weeks just in case they do the same with the thc upgrade. Cant wait to order one.

So for those of us that have the older electronics, when / how can we get our hands on the new box?