Need some technical help please

I believe my control board is down.
I have been using this thing flawlessly for four months. Its great and business is starting to take off.

Friday i went to turn on the machine and it just clicks, repetedly, and the status led on the cutting head flashes green.

I have power to the motors because i cant turn the rails by hand.

Inside the electronics box The LS-THC module has a flashing red LED in the PWR slot.
There is also a flashing green led up by where the usb cable plugs in. All other leds on the other components are steady green and all fans run including the power supply.

I powered off the machine, unplugged power cable and removed the LS-THC module and the flashing stops but will still not connect. I have tried two computers both with the latest fire control and usb driver installed.

I called tech as soon as they opened and was told to call again when i got home from work and that some people work late, 530 EST 430 CST I called back continuously for 30 minutes. It hangs up on you after 2 minutes.

I am sorry to vent i am usually not that type but langmuir did not respond, to the calls or the email i sent in at 9:30 and i have large jobs that are backing up i need to get done. I am just starting a business and for the table to go down when i need so much out of it is horrible.

Please help as soon as possible. Thank you

Have you checked the usb and HDMI cables to make sure they are plugged in all the way at computer and monitor?

1 Like

Yes sir, I have checked the usb cable. I tried two different cables and a different computer as well.

Zach with technical support reached out to verify some information. I am going to run a multimeter against the control board when i get home and hopefully we can fix this issue.

If you want to see what the machine is doing i have attached a short.

@FoothillsDesignNC Has Zack followed up with you on this issue?

Yes, I measured all of the voltages across the power supply and everything checked out. A replacement Motion control board has been shipped. I am waiting for the replacement and will post the results.

Thank you