*Need Help: CrossFire THC & Razorcut Weld 45 Issues After Long Break**

Hello everyone,

After about a year of not using my plasma cutter setup, I’ve encountered some issues upon trying to get it back up and running. I have a 1st generation CrossFire with a THC kit, and my plasma cutter is a Razorcut Weld 45 with a single blue port.


The last time I used it, everything worked fine after I corrected a wiring issue (swapped the RED and BLACK THC wires to their correct positions). I’ve now updated the firmware, lubricated all moving parts, and performed a system reboot.

Current Issue:

However, during the THC trigger test, the system fails to trigger the plasma cutter. Manual tests show proper voltage readings (130v at the plasma wires and 1.38v at the THC port, consistent with the troubleshooting guide). Yet, the plasma cutter doesn’t trigger.

Specific Points:

  • The plasma on/off control isn’t connected to anything. Should it be?

  • The PV output is connected to the THC on the control board.

  • The module box is temporarily placed on the floor.

  • The DIV input is correctly set to the plasma.

I’ve already reached out to Langmuir, hoping for a quick response as I need to use the cutter urgently.


  1. Has anyone experienced similar issues or have any troubleshooting tips?

  2. If I need a replacement THC chip or board, how can I order one quickly?

Appreciate any advice or insights from the community.

If you are asking if torch fire cable needs plugs in to fire plasma cutter, yes it does… The torch fire cable plugs into table control box port labeled torch on/off and other end connects to plasma cutter torch wires to fire the torch. THC has nothing to do with firing the torch. So, make sure you don’t have torch plugged into the THC module box or crossed at the table control box ports. Make sure you have at least 100 psi air supply to plasma cutter from compressor and check that plunger in torch moves up/down freely with consumables removed…


As mentioned above, the torch on/off wire must be plugged into the electronics enclosure where it says “torch on/off”. That connection is the only way that the software can tell the plasma cutter to fire the torch.

There is nothing in the THC wiring that can tell the plasma cutter to fire.


Thank you for replying back. Ok great! I have a dumb question. My plasma is at my friends shop and they moved it around. Donyou mind sharing a picture where that torch on/off goes to please. I dont see anything loos that would go there. Unless one of his employees took something out that im not aware of.

thank you for replying back gentlemen. I found a image to what my plasma cutter looks like. its identical to this image. currently nothing is hooked up to that blue port. is that where the Torch on. off goes to? I wish i should have taken a picture before when i had it working. My friends employes moved it around and might have disconnected and tried to reconnect things. so fustrating.

Heres what I drew up. Is this correct?

I don’t have a razor cut machine, but that blue port on front should be where the torch on/off plugs into.

1 Like

As mentioned, you do not have your torch on/off cable connected hence why it does not fire.

But you also stated something that…doesn’t make sense and surprised it wasn’t caught.

When connecting to the VIM (the small black box), the OUTPUT used is dependent on the INPUT used.

If you use the two separate black/red CATIII cables that connect to the face of the box, you need to utilize the PV OUTPUT.

If instead you use the barrel plug and connect it to the DIV INPUT of your box, you need to use the DIV OUTPUT from your box to the THC port on your table.


Thank you. Much appreciated. Got into the shop and took the wire going into the DIV input and put it in the torch port and SUCCESS! IT WORKS! Ihave to do a simple drawing and lable these wires incase the employees decide to disconnect things.

1 Like