My fire control won't jog my machine

Just hooked up the computer to my machine everything is lit up green saying it’s connected to the controller, but it won’t jog, the dro is indicating that it thinks it’s moving but the machine won’t move. I checked for updates and updated the firmware. I’m not sure what else to do

I cant help you with that other than letting you know you can search the forums by clicking on the magnifying glass in the top right of this screen

Do you have power switch on the control box on?

Also check your motor plugs.

1 Like

I’ll second the power to the control box suggestion. The control box doesn’t have to be powered on to show as connected in Firecontrol, but nothing will work if it is not powered on.

Yeah I have been in a hurry before did that. I don’t like to admit it though.


yes I have the power on to the control box. and double and triple checked all connections. I can see the little led light inside the controller flashes while idle and when I press a jog button it goes solid.( I can see it glowing through where the USB plugs into the controller) so there is communication up till that point.

Also, my dad has the same set up and can plug his computer in and it works just fine, both new computers with windows 11 and we downloaded everything the same.

Sounds like a USB problem if using the same cord. Have you tried different ports on the computer?

yes both ports that are on the computer

Have you tried you computer on his machine? Seems if it works with his and not yours there is something wrong with your computer. That is if drivers did install correctly.

If you have a wireless X-Box controller you could map those functions and try it. A lot of us use those for standing at the table and positioning the torch.

That might help you understand if it’s the drivers or the USB port/outputs themselves.