Multiple piercings

File with multiple piercings don’t fully pierce?
Seems like the pierce delay is 0?

What did you set the pierce delay to in whatever CAM program you are using?

If you upload a cut file, we can see what might be wrong with it

Using sheet cam,
This recent one pierce delay .5,
Seems the pierce delay only applies to the 1sr pierce?
Current file Harley eagle from file share,
I get the same thing on any file with multiple piercings,
Last project was aluminum had to spend an hour on the jigsaw to finish it

harley eagle17.5.tap (119.4 KB)

I can’t tell you how the title of this thread brought back some very scary memories!


What plasma cutter are you using?

That file was made using the TD retract version of the Firecontrol post processor, which adds 2 seconds to the first pierce for Thermal Dynamics plasma cutters. The first pierce delay in that file is 2.6 seconds and the rest are .6 seconds.

I would also slow down the plunge rate a bit to about 50-60 IPM. 80 IPM is a bit fast and may be adding to the pierce delay issue.

Razorweld 45,
The file was dfx loaded really small I enlarged in Inkscape saved as svg then brought into sheetcam

Ok. You’re using the wrong post processor in Sheetcam. There are a few different ones in Sheetcam that have been modified for various reasons. The one you’re using was modified to work with Thermal Dynamics plasma cutters. You need to switch to the plain Firecontrol v1.6 post processor.

The one you’re currently using adds 2 seconds to the first pierce delay. You will never be able to figure out the proper delay settings for your machine with that post processor.


Thank you, I’ll have to look into that.
I don’t see any other file available?
Perhaps I didn’t get in installed correctly?

If you have a recent install of Sheetcam, the post processor is already in the library. Go to “Options”, then select “Machine” and click on the Post Processor tab. Click on the post processor drop down menu and select “Firecontrol v1.6”

There is another one in there labeled “Firecontrol v1.6_TD mod retract” . I believe that is the one that is currently selected, based on the added 2 seconds on the first pierce and the 2" retract height. You don’t want that one unless you have a Thermal Dynamics plasma cutter.


I will look in to that this Evening

So glad I had read this thread because I just encountered this issue and this was exactly my problem. I restarted and the first pierce worked but it would always stop at the next. This is the very first thing I have had SheetCam process a G-code. Been using Fusion 360 but it balks at anything smaller than 1/8 inch hole. I now see why many of you like SheetCAM. I am exhausted from trying to lean all of the programs and terminology. But still having fun. Fusion 360 is nice to learn but then I tried Solid Edge and that is pure magic (but lacks the CAM). Tried to learn SheetCAM twice and bailed. This was my third attempt because Fusion 360 failed me. So thankful for this post from @ds690.

1 Like