Major THC Issues with the Crossfire Pro/THC & machine disconnect

New to this board.
New insall Dec 2022
CrossfirePro with THC
Everlast 62i CNC

Afer assembly, I ran the fire test, It failed, I got Zero voltage. Here is report text
THC health check report 12/30/2022 ------


[11:12:56] average voltage = 0.00V


[11:13:14] average values: [0.00V] [0.00V] [0.00V]

I tried this test with the 1/50 Divided voltage via CNC rear port on my Everlast Plasma 62i (CNC). Then I tried it via the Raw voltage, again via the rear CNC port connector I finally tried with Raw voltage directly connected to the terminal inside the case (thus voiding my warranty!)

I can fire the torch successfully and I can cut a straight line with THC off. I completed the troubleshooting using both the 1/50 Divided voltage via CNC rear connector as well as Raw voltage directly connected to the terminal inside the case. The two had the same outcome.

Here are the results of the trouble shooting with the Raw voltage directly connected to the terminal inside the case
Testing voltage at cable free end from vim box
voltage value 1.4 volt with No voltage in FC. ==> further troubleshooting

Further troubleshooting:
Step C2. Verify that reference voltage to the LS-THC is correct
Result: voltage between the REF pin and the GND pin = 4.09 volts,

Step C3. Verify that the LS-THC resting voltage is correct.
Result: DC voltage between the A1 pin and the GND pin = 0.000v

C4. Verify that the LS-THC cutting voltage is correct at the THC unit
I performed a straight line cut with with the THC panel toggled off in FireControl and measure voltage
during the cut
Result: DC voltage between the A1 pin and the GND pin = 0.000 Vols/MV

Since I was getting no voltage reading here but measured a voltage out of your VIM box (4.09 volts in the previous troubleshooting steps, I checked for continuity between my VIM box and the Motion Control Board.

I traced the two THC wires that are plugged into the white Motion Control Board back to the VIM box and confirmed that there is indeed continuity.

I have the plastic spacer between my electronics box and the machine frame.
I am running fire control off a Desktop and not a laptop

Have you tried reversing your polarity?

Your plasma cutter is a electrode negative work “ground” clamp positive electrical setup

The plasma is a electrode negative constant current power supply.

Getting the polarity wrong is common considering it’s counterintuitive to most wiring setups.

Just an idea might not be your problem welcome to The Forum


Yes I did. Thanks

I run an everlast 82i. I recently was setting it up with my crossfire pro and had the same problems. I opened up my machine and measured the voltage coming into the cnc board and read 0 volts there as well. After some back and forth troubleshooting with everlast tech support they replaced my unit.

The new one came in and i was able to read a voltage within the acceptable range across pins 5&7 so my unit was definately not functioning properly.

Everlast tech support kept telling me to just wire it up directly to the lugs on the inside of the machine but i was annoyed that the machine wasnt even sending voltage to the cnc board correctly.

Thanks for you input. I am reading voltage between pins 5&7. That is not my issue here.
I am glad you got yours resolved.

I run a 62i on my pro…and I solved a lot of problems by taking raw voltage right from te lugs inside the plasma near the front…
if you search for 62i you will find pictures I posted here.

I never trust the pins for divided or raw voltage…go right to the source

1 Like

Hi Toolboy.
Thanks for the suggestion. I am running with raw voltage straight from the lugs inside 62i. I get the correct voltage all the way to the THC white board.

On a separate note/issue, I am also getting a lot of freezing when I cut (straight line so far). Where do you place the 62i relative to the control box? Are you having these issues too?

@AlexT Hi, I have the 52i. I put the control box as far as I can from the control box and from the Laptop. It appears to me the weak link is the usb cable connecting control box to laptop. If any cables attached to the plasma machine get anywhere near that usb cable I get the loss of communication and freeze up of system.

1 Like

so I have found the following…

  • USB cable does not cross with other cables
  • USB cable has a ferrite choke on it
  • do not coil lines to much…keep them loose and away from each other
  • laptop runs on battery or through a ground isolation plug adaptor
  • ground directly to material cutting
  • control box and plasma are not sitting beside eachother…

Thanks for the feedback back DnKFab and toolboy !

1 Like