Machine torch wont fire

I finally got the XR all put together and went for my first cuts and the machine torch for the razor weld 45 wont fire. I’ve checked all of the wiring checked the 2t4t setting and nothing seemed to make it want to fire. hooked everything back up to the pro table and hand torch and everything fired and worked perfectly. the only difference I’ve noticed is that the two longer pins on the hand torch aren’t longer on the machine torch. is there anything else I should look for?

Depending on what machine and torch you have it may be a lockout. I have the Hypertherm 45XP and the machine torch has a lockout swich at the top of the torch unit. It’s a small slide switch where the torch meets the cable. If not that I’m sure others will need more info about what plasma and how you have it hooked up to help you diagnose the problem.

I’ve had the same issue. if i unplug my razorweld its like i have to setup all over again because it wont fire. I check all my connections, test the THC and dry fire the torch manually in fire control system. It always works after that.
Try testing/calibrating your THC in fire control or dry fire it.

Sorry yah it’s a razor weld 45. I tried to test the thc and it won’t dry fire either.

Its the torch, if you got it from Langmuir you need to contact them and get a new one. If you got it from Plasmadyn contact them and maybe they will take care of it.

1 Like

Well I really was hoping it wasn’t the torch. The only other thing I’ve been able to make it do is run the torch down basically to cut height and then mess with the button settings on the front of the plasma and get it to strike one time and then obviously it won’t do it again if I try to run a program. Is there anything else anyone can think of that I can check before I order another torch?

I just ran into this problem last week. I thought it might have been the “compatibility” update I installed. Apparently my graphics can’t handle the latest firmware…so I installed a compatible version and thats when my torch quit firing…I was getting a “cutting voltage not detected” error. Is that the same error you’re talking about? So, turns out that my OS needed a lot of updates, after that I was able to again install the FC 24.1.4 , then I checked all my connections, particularly all the ones in and out of the THC box, Cutter, and Electronics box. then I fired everything up and I’ve not had any issues since. so to sum up…for me, the issue seems so far to be software update related…hope this helps…good luck!

P.S. I love your XJ…I’m building mine up too :wink:

Yah that’s the error I’m getting I’ll try to update everything tomorrow and see what happens! Hopefully that fixes it.

But thanks man XJs are my jam! it’s been a huge long project and I’m finally able to be out enjoying it! Also just finished up another one for a buddy!

1 Like

That’s awesome man, well good luck with the updates!

So what all did you update? I want to make sure I get all of it haha

So right now I’m using the computer that came with the XR…but personally I really want to run this thing from my iPad… I updated it’s OS as much as I could because it was behind like 20 updates sitting on the shelf for so long in the Langmuir facility… then I’ve updated the actual FC software. currently running 24.1.4…tho, I did read in another forum today that they came out with a 24.1.5…maybe it was a typo because I went to the downloads page today and didn’t see a newer version than 1.4…so…idk. aside from the updates, I unplugged everything and reconnected everything to make sure all the connections were good and so far im still in the clear with my cuts…keep us posted if that works for you!

So…today I got the error again…torch wouldn’t fire. I again turned things off and then back on again and nothing…so, I remembered reading about some possible interference issues if the USB cable from the electronics box is touching the table or twisted or wrapped up with other types of cables…so, I turned everything off and routed all my wires differently and more “isolated” from one another. I had all the THC cables crossing power cables and the plasma torch lead and pretty much everything was “touching” so now…its not pretty, but all my wires are not crossing major paths with each other now. my usb cable coming out of the electronics box isn’t touching the table itself or any other wires and the THC wires follow their own path away from the plasma torch lead and so on. I turned it all back on and it cut the project perfectly…I don’t know if this is a long term solution or even if “cable management” was a factor in getting the torch to fire again but…maybe its something to try if the updates don’t work.

So I updated everything torch still won’t fire with the computer. But it now will fire if I test it with the buttons on the front of the plasma itself. So I’ll try rerouting all of my cables and give that a try all of my cables are ran together so maybe I’m getting a ton of interference. Thanks!

Can you hear the relay inside your electronics enclosure click on when you manually fire the torch in FC? Also, you can try just jumping the torch fire cable with some copper wire or paperclip even to see if the machine torch will fire without any Langmuir components connected at all to eliminate faulty electrical components from the equation. If you’d like to give me a call I’m here weekdays 730-345CST @9362353991


So I’ve ordered two different Cnc torches now the wiring on both is different and neither one works. Would someone be willing to pull the End that goes into the plasma out and take a picture of the terminals and send it to me on here so I know which one should be correct??

The machine torch for a Razorwekd 45 only needs 2 pins, the long ones in 1 and 9. They are the positive pins for the pilot arc.

I’m having this same issue, I don’t hear the relay firing in the control box. I’ll try jumping the pins and see if that works.

Ok juping the cable got the torch to fire!!! So my problem isn’t the razorweld.