Machine slow to respond to Firecontrol?

Got my machine mostly assembled on day 2! I am running the break in program and jogging it around. I am finding there is a significant delay between pushing a button in firecontrol and the machine reacting to it. For example; if I tell it to jog X+ continuously by holding the right arrow key down it might take 10 seconds and then it jogs for some very uncertain amount of time after I have let up. I am using Windows 10 and the latest version of FC. I know that people have some freezing issues with that combo but is this a symptom as well. Or is just the way it works?


Mine does that on the newer versions. Had to go back to 20.6.2.

Thanks Bill!

Hooked up my Macbook and it worked as I would have expected. Apparently the windows laptop aint gonna get it done. I did have the older version of FC on it already.

I haven’t messed around too much trying to figure out why, but for some reason if I uninstall and delete all the FireControl software and then install the new version it works fine until the program is closed or the PC goes to sleep or shuts down. Once I reopen it, it does the extremely slow response. The older version doesn’t. I wish I could use the newer one, because I use a touchscreen and have to use the stupid little windows keyboard to enter values.

1 Like

If you are seeing this, especially after switching between versions, definitely remove the .FireControl folder in your Users folder (on both Windows and Mac). The current version you are using will replace this folder.

If this doesn’t help, please shoot us a video of this to support with any other information you can about your computer/usb/crossfire setup.


I’ll try it and let you know!

I actually am using the 21.1.5 compatibility version, I deleted the .firecontrol folder and it is just as responsive as the mac now. Thanks for the help! I’ll make some cuts and see how it goes!

1 Like

I have run into this issue occasionally. In fact I just ran into it the other day. Its usually because I have windows updates pending. If I tell windows to install the updates and reboot it works fine.


I had to delete the .firecontrol folder again the other day. @langmuirsystems

1 Like

Ok today I can no longer solve the problem by deleting the .firecontrol folder. Will forward to support.

Firecontrol compatibility version 21.1.5

Device name laptop-spare
Processor Intel(R) Core™ i5-2410M CPU @ 2.30GHz 2.30 GHz
Installed RAM 8.00 GB
Device ID 3167AE83-294D-460A-A89F-D9AC3F82EE5B
Product ID 00331-20300-00000-AA339
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Edition Windows 10 Pro
Version 21H2
Installed on ‎4/‎24/‎2022
OS build 19044.1706
Experience Windows Feature Experience Pack 120.2212.4170.0

Video of behavior Machine slow to respond to firecontrol jog commands May 24, 2022 - YouTube

I just solved this problem in my setup… the issue is the video drivers in your machine…
in my case I have three Dell 6520’s two have the Intel HD Graphics 3000 board in them… these two do EXACTLY as you are describing… the third 6520 has the NVIDIA NVS 4200 M board and drivers… the PC runs FC perfectly…

All three PC’s have SSD and 16Gb RAM…

And I did try all the other steps mentioned by the others…


1 Like