Machine freezes in middle of cut (Solved)

The problem is before I tried the new power supply the crossfire would freeze. The new PS would power anything. Ten when I re installed the old PS the crossfire quit freezing and the torch won’t stay on. Before I started the torch was working fine.
Once I got the old PS back, the light on the top control board didn’t come on till I went through the steps I used to unfreeze (ie power on, power off, unplug then plug and power) at that point the light came on.

CAN you wait till Monday to ship? I’m going to be gone till Wednesday and don’t want it to be sitting on my front porch. I’ll also send you back the power supply I just received.

Hold off shipping, I’ve got the torch staying on for the most part. My dryer isn’t keeping up so I’m dumping it and the bowl periodically and that seems to be helping a lot. The cutter has been running almost continually for the last 2 hrs.

1 Like

Great news @Grouse! Glad to hear you were able to get it up and running. Please let us know if you have any further issues.

I think the problem was not the machine at all but the cable. If the usb connector fits loose. If you bump the cable or the laptop strange things happen. There is an easy way to check this. Remove the cover on the control box and go back to cutting. There is a small light at the top of the board when communicating properly it will be on or blinking. If it goes out then the cable has cause the computer and the controller to lose communication. Very simple check that can eliminate several hard to diagnose problems.


The plasma cutter is about a foot away