Mach3 seems to be pausing

I recently bought a hypertherm powermax 45xp( had the rw45) went to cut my 1st sign since the upgrade. And with the book settings of 225in/min it seems to pause or slow down well below 225 anyone have an idea of what could be going wrong or let me know if I’ve done something wrong

Have you had a look at your settings in either the gcode file or also in Mach3? You set them when you do the setup in fusion360 but you can override in Mach3 manually…

What setting am I looking for the only setting I changed from going from the razor weld 45 to the power max 45 was obviously added the new tool to the library and speed in a shorter period delay other than that I haven’t changed anything and have caught several signs before this issue

Pausing or slowing down when cutting corners or changing direction? The machine slows down on intricate patterns and direction changes, there is a ramp up to the cutting speed after it changes direction from what I understand. With 225ipm you’ll notice it more than a lower cutting speed.