Mach 3, X & Y values incorrect per actual measurement

Hi all,
I’ve assembled my crossfire and ran the break in program per the instructional video without issue. I created a simple part (triangular axle bracket) that is approximately 4 inches in total length. I created the G code using post processor in Autodesk Fusion 360. I did a “dry run” without firing the plasma cutter just to verify tool path was correct. Part profile was correct, but was about 4 times too large. I closed the G code and manually jogged the machine 1 inch per the mach 3 coordinate readout and physically measured from a reference point. Distance is approximately 4 time farther than readout, moved 4 inches, reads 1. As far as I can tell all units are in inches, both Fusion 360 and Mach 3. Any assistance would be appreciated.

This happens on both axis?
If only one axis, then I’d suspect that some of the switches on the driver got knocked out of position. If both axis, then it’s not clear. Maybe Mach 3 profile isn’t set right.

On the Y axis, all the switches are positioned in the same direction. On the X Axis one switch (controlling motor current) would be opposite all the others. I don’t have the electronics in front of me so I can’t tell you exactly what they’re set to.

It’s effecting both axis.

Make sure the box to the right of the readout says 1, and isn’t blinking yellow… Says scale in the box…


check your motor tuning settings in the configuration menu, I can’t remember the correct number off the top of my head, but that number or somewhere in there, tells it how many revolutions of the screw define a 1 inch move, or something along those lines… Thats about all that would cause that… You could download the crossfire xml file from the langmuir site, and re-copy it into the mach 3 directory, that should fix any setting issues…

1 Like

Make sure you installed the mach3 profile from Langmuir. I would just reinstall mach3, following the instructions on Langmuir’s help page. I know I managed to install it wrong when I first setup my table, mainly because I rushed the install and didn’t think anything in the install setup was that important.

1 Like

That’s just funny.



Hi everyone,
thank you for the assistance. I simply opened the wrong Mach 3 profile, I opened “Plasma” and not the “CrossfireV1.1”. All is well.


you can delete the other profiles from the list and just have the crossfire visible so you don’t accidentally select a different one.

1 Like