Mach 3 table movement scale wrong

I bought a new computer to replace my primary, and have an older one I am going to use for the garage to control Mach

Everything worked as it shouldve when I last used my now defunct laptop on the table

Reinstalled fusion on the brand new laptop

The older laptop I am going to use in the garage has windows 8

Ive installed mach3, full version.
Ive installed CrossFire Mach3 USB Motion Controller Plugin
Ive installed CrossFire Mach3 Profile

When I jog the table it will max the X (and Im assuming Y) axis out completely and only show 4" or so on my screen. 5"ish of travel on the table is only about 1 in mach

Scale reads +1.000 on all the axis’ in the mach controller

Again everything worked fine on my now defunct windows 10 laptop, I doubt its a hardware issue the table physically is moving fine.

The torch is also not firing. Im not sure if thats software or not. The machine itself does work when triggered manually.

Could it be your “Native Units” in Mach3 config?

  • Start Mach3
  • Select CONFIG tab
  • Make sure it’s set to inches.

Just a thought… Good luck!!

Forgot to mention it, but that was checked and confirmed correct.


But did you choose it when you started Mach 3?

I believe I did a few times at startup and then clicked a “dont ask me again” checkbox

Where do I check to confirm?

In the Profile box on the lower right of the Mach 3 screen you should see CrossFire-v1.1, if you don’t then the wrong profile is being loaded and that would certainly mess up any operations. I’m not sure how to revert Mach 3 to asking about your config on startup, I’ve never selected “don’t ask…”
Reinstalling Mach 3 wouldn’t be terribly difficult…


Fixed, total reinstall of Mach. I believe I picked the wrong icon to keep on the desktop after install when theres like 5 or 6 on there

You want the Mach 3 Loader icon.

1 Like