Mach 3 stopped firing torch all together

So ive been having issues with Mach 3 not stopping and starting the torch firing for a couple days now, it seemed intermittent.

Now the program will not fire the torch at all, after cutting for about 6 minutes I moved to a new program and loaded it. now it won’t fire the torch when M3 shows up and it won’t even fire the torch with the manual torch on/off toggle.

the torch is fine, i can pull the trigger and get an arc going.


I had trouble with the wire taps not making a good connection where I tied in the torch control. Worth a look anyhow.

1 Like

Had this issue the other day as well. Running a hypertherm powermax45 connected through the cpc port. Checked everything over and it needed up being the plug into the control box. Once I unplugged it and plugged it back in the torch would fire again.

1 Like

I have tried disconnecting and reconnecting all cords to the control box, computer and cutter, cycled power and restarted and reset everything computer and electronic. Crossfire will move the gantry just fine so it has to be something between a circuit board and the torch connection.

On a side note, when I initially setup the torch, I never got perfect continuity between the trigger wire when the trigger was depressed. multiple tries and it was between 200 and 400 ohms, while the other two were perfect continuity.

Maybe a torch trigger issue? Manually, the torch does not always fire on the first trigger pull…

What plasma cutter and torch are using

Razor weld razor cut 45 and the included torch.

I guess to be more specific the torch is TRF45-6–CC1 19’ Suregrip TRF Plasma Cutting Torch, with the Razorcut 45.

That suggests something is up with the torch. Did it do that before you wired the bypass for the Crossfire?

Thanks for the ideas/help. I took apart the torch and cleaned up the trigger contacts.

I think that the culprit was a poorly connecting female end of the splice connectors in the plasma cutter. I plier’ed them tighter and reconnected.

One of the two (likely the second) was the culprit. seems to work fine now… on to find another forum to ask about the other issues I’m experiencing.


1 Like

Above is what I ran into with the RAZORCUT 45
Same as you it worked fine then started intermittently not firing then stopped all together

Also I find the the tungsten electrode comes loose after a few projects and causes an intermittent no firing of the torch.
So after every cut or two I remove the nozzle and check the electrode and nozzle
So far
Smooth sailing.