Mach 3 program run issue (g code?)

A few weeks back I ran into an issue where some how the Mach 3 profile was not recognized. After some forum searching I just reinstalled everything and it worked fine. Fast forward to now and when I hit start to run the file it will jog to the first cut, torch will fire but it does not move from that spot automatically.

I’ve found a work around but it’s very annoying on complex cuts so I really need to find a fix. (Work around I’ve figured out is once I hit start I need to go into the tool path alt4 tab and once the torch fires/ g code is at n__ m3 I can hit start in the screen. Keep doing this as the g code runs down the line.

I’ve added some photos of what the g code looks like when I originally load then once started and gets stuck.

*even if the plasma is off it won’t runout then full g code, it gets stuck on the first torch pierce.

Razor weld 45 with a hypotherm torch.

Thanks for reading/any help!

Check your config and make sure your G4 code is set to milliseconds, not seconds. It’s in Config->General Logic Configuration, fourth column, second check box down. G04 Dwell in ms should be checked.


i would agree with TomWS. if it’s set to seconds then the “N30 G4 P1300” is 1300 seconds which is around 22 minutes.

Once I get home I will try what both of you have suggested. I appreciate the input already :raised_hands:t2:

You’re the best. Thanks. All set. Thank you.

Now that I’m back in front of the computer doesn’t the 1300 (in my case) represent the time given for pierce delay?

In fusion when I go to simulate I have it set at 1300 for the value, is that too high?

Yea that’s the pierce delay… you stated it fires and just sits there and doesn’t move… well if you’re m4 dwell in mach3 is set to seconds then it’s reading the 1300 as 1300 seconds which translates to 22 minutes. If you haven’t changed the dwell to milliseconds then change the 1300 to 1 and see if moves after 1 second.

1 Like