Mach 3 Pauses in middle of file [SOLVED]

I recently picked up a used Crossfire. I downloaded the demo version and have run a couple of projects. Both projects seem to have a had over 500 lines of code and the software never stopped from completing the files. However, I’m now on my 4th project and the software seems to stop midway through the file.

Before I invest in the software, anybody else have this same issue? Was it because of the trial limitations? Does the demo allow you to run a certain amount of full code projects before cutting down to 500 lines?

I’ve uploaded both files for comparison. The file labeled “ViceMountTop” has had no issues completion, however the “CasterPlate” file seems to stop mid run. I checked and unchecked the Dwell ms option as well as restarted computer to no affect. I can still run Visemount project no problem.

CasterPlate_4_45.tap (31.9 KB)
ViceMountTop.tap (10.7 KB)

Welcome to the forum!

According to Mach 3 website, the Demo version has the following limitations:

Without a license, Mach3 will operate in Demo mode.

While in Demo mode, the software has the following limitations:

    Mill & Plasma: 500 line gcode limit (10,000,000 limit after licensing)

From: Newfangled Solutions Mach3 Licensing/Demo Mode

Given that you’ve spent some amount of money for your system, buying Mach3 seems worthwhile, I’ve been using it since 2019 on three different CNC systems, including my Crossfire system. Langmuir Systems used to offer a discount on purchasing Mach 3 from them, but I’m not sure they still do.

1 Like

I ended up just breaking down and buying the software. I will try and run the code again and see if it makes an difference. Wondering why the demo ran other code just fine with more than 500 lines.

in the file that wasn’t finishing, does the full pic of the castleplate show up in the mach3 window? if not then it was over the 500 lines of code.

It didn’t. The ViceMountPlate is 433 lines long, the CasterMountPlate file is 1300 lines long.

I’ll mark this as Solved.


Thanks for the responses, buying the license did in fact solve my issue.