Lost connection at the end of cutting a part on Pro table(Solved)

Having trouble diagnosing this problem on my Pro table.

I can connect my MacBook to the controller and cut single and repeating patterns just fine. Everything works perfects on the MacBook.

The problem occurs on a Beelink mini PC I purchased to dedicate to running Fire Control. It will always make it to the end of a part (in this case a simple rectangle with a hole). Then it loses the connection to the controller. The app freezes for a minute and both the controller and THC indicators are dark. Once the app unfreezes I have to unplug/replug the USB cable to re-connect.

The interesting bit is the connection always seems to drop at the end of cutting the part. Or, if I pattern the part, it always drops at the end of the first part.

Specs: Windows 11 Pro v21H2, build 120000.2205. AMD Ryzen 7 5800H with Radeon Graphics, 32 gigs ram.

Unfortunately I have to run the “compatible” version of Fire Control on this machine. The normal version quits with the “Child Process Exited with Code 1” error. No idea if that is a complicating factor.

The USB cable does not run near the plasma cutter or the torch lead. I’ve double checked with an ohm meter to make sure no connection between the table frame and the USB shield or any part of the PC or monitor. And as I mentioned above, my MacBook in the same location has no problem cutting dozens of parts at once.

Final bit of info, a Dry Run with the torch off works fine on the PC. Will drive the controller through multiple passes without an error.

Is the Beelinks monitor have a grounded plug on it? If it does you might have a ground loop through the grounding pin on the plug. I know the Beelink uses a power supply without a ground. So the monitor could be your issue. EMI is like VooDoo.


Solved, but that was not the problem. I replaced the monitor power cable with one missing the ground prong and it still failed.

I realized one difference was that the controller was connected to my MacBook via an Anker USB Hub since the MacBook only has USB-C plugs. The controller was plugged directly into the PC.

I switched the PC to the same hub and now it seems to work fine! I cut several individual parts and a 2x2 pattern and they all worked.

Thanks @Bigdaddy2166 for nudging me to troubleshoot that further. Time to buy another one of those hubs.


Glad it worked out … Happy cutting!