Licensing my Mach 3

so, i got ahead of myself and downloaded mach3 and was having trouble getting everything up and loaded Got semi set up and messed up and deleted my mach3 licensing path before putting into my mach3 download Now through Newfangled Solutions it tell me Ive reached download limit which I understand Question is how to go about re-downloading the path so I can drag it into Mach3 and get my full version going Thanks in advance

You can go to there site , log in and there is a resend option on it. Not sure what its exactly called .If you send then a email explaining they will direct you in the proper way to get it resent. ( I did the same thing )

1 Like

Did you check your recycle bin if it was on your computer if it was in a email check your trash email folder. Just a thought.

My Mach 3 registration code isn’t working? Now what?

I printed the email they sent me with the code. I am typing in the code on the Full Version site but its saying its not valid
.

I do have the code, but its not excepting it on the site.

Email support there, and tell them your problem. There very good at getting back to you and explaining things. I talked with them a half dozen times and they explained in detail once they figured out what I was trying to say. Its been a couple months since i went through that stuff. Can you copy / paste to the place it needs to be?

Hi Jim. Now I cant incorporate my MACH3 license into the system to get it out of demo mode? Do I email the people I got the MACH3 license from or email Langmuir… unless you know? So freakin frustrating, but I’m sure you’ve been there. :frowning:

Hi there, I will get someone on our end to reach out to you. They should be able to help you fix whatever issue you are facing.

Yea I looked there too. I am now having troubles entering the license into the system, to get it off demo mode. I read another post saying that the art website started to not send as a zip file, but a down load. I have the file, just cant incorporate it into the system to get off demo mode

Hey Michael,

I just resent you the email with your Mach3 verification code from our customer support email address. Can you confirm that the code in that email is the same one you are trying to use? You can reply to that email address so we can figure this out together.

-Aksel

This is EXACTLY what I am going through EXACTLY!! grrrrrr

Ok going to go look now. Thanks

Hi That is me & I replied back to you. Thanks

Ok Thanks Appreciate the assistance for sure!

Getting things ironed out? I started on the wrong foot with my .lic. I watched a couple vids on it and they were old ones. had a zip file in it. I was lost when i got my email. No zip lol. Bone head me . Took about 3 days but in the end all was well.

FINALLY… got rid of the demo & was able to install my license woohoo. Now onto learning to learning how to design. What was the first thing you made Jim?

First thing I made was a 2x2 peice of scrap metal. On that peice i just tried diff speeds, amps, air pressures. used a couple of the tap files that was preloaded onto mach. Being totally new to it all I figure it was a learning experience. Then I took a mery christmas off of fireshare. Worked awsome and gave me some hope. With the help of the kind members who have past experience, reading all i could ,im doing ok now. And trust me. The only dumb Question here is the one you dont ask. After a few projects i started making some signs. nothing big just learning fusion 360. Doing them basic signs helped me learn so much. I posted some of the projects i made, Nothing spectacular but , I made them :slight_smile: And so many times I thought ok this isnt for me. Now…Omg its so fun making and creating things no matter how small.

LOL. That’s what I did. Cut out a square. Then a couple of circles and a couple different sized squares. Then jumped into a more complex art sign project I scaled up from a laser project I had done earlier :slightly_smiling_face:

Now my biggest issue is life getting in the way of time on the table. I have 2 more things queued up waiting for next weekend after I cleanup other obligations this weekend. The next couple of things will be colored with acid patinas and a powder-coated one that let’s me play with that new setup.

I can’t even get the Mach3 to open, I downloaded with directions of the videos and when I click on The Mach3 icon on the desktop it opens so I click ok then I get a message that pops up saying Plugin DLL Defective. Reload… hit ok then Flash DLL- Defective Plugin Found… ignoring… I hit ok and it goes back to Plugin DLL Defective. Reload this process just keeps going over and over… very frustrated. Just got my crossfire in and can’t do anything… of course no number to call for support… Help me Please!