Jogging issue fb no help

Well I need suggestions. Tried cutting today and it won’t move or home.
Manually jogged it and coordinates didn’t change.
Hit buttons and it moved on screen but never moved torch or changed coordinates.
Hit limit switches and they both error editing out saying I crashed.
Restarted firecontrol 3 times and laptop 2.
Saw no loose wires with cover off.
Did notice on the last try that the fan wasnt kicking on but thc and motherboard were good.
Also tried changing USB ports.
Has there been an update recently?

One of the limit switches is in alarm. My advice is to take them off and throw them away.
Click on the three lines in the top right corner of your screen. Go to machine settings. Turn off limit switches.
Your problems are gone. Click on the red Adobe text to see the instructions.


The table works perfectly without them. They have no purpose, in my opinion.
Except in the remote future, you index a large sign larger than the table. Otherwise,
just drive the torch over to where you want it and start cutting.


Turn off the limit switches and see if it will move when you jog it. If it still won’t move, but it shows movement on the screen, your DC power supply is probably bad. If the DC output is too low, the stepper motors won’t move.

Test the DC output of the power supply inside the control box. It should be putting out 36v DC.


I make signs, worth the price. Also ran with them off cause that occurred to me, no change

Ill give that a try next chance i get thanks

I also tripped them individually and they seem to work just fine

Unplug them from the control board if you can’t clear the alarm.

If one of the limit switches is actually being pressed, turn off the table control box and manually twist the lead screw to back the gantry away from the switch. Then turn control box back on and hit “HOME”. Lassie should find its way home then. :upside_down_face:

If there is not a switch that is being pressed, one of them is acting like it is. That is a defective switch. I never tested whether the switch is normally closed or opened. I will go check now. BRB.

Edit: Those switches are in the normally closed position. When tripped, they open. That means any broken wire or bad connection can simulate the switch being tripped.


Jimmy, you have limit switches on your table? I thought we were friends. :smiling_face_with_tear:


BigDaddy, it is all about the extent that I try to help around here!

Let’s just say I have “Limit Switches waiting for a purpose”

I turned off the soft limits and literally only use them to home the machine at the end of the day.


I have limit switches on my table. Are you going to disown me too? :grimacing:
Of course, I don’t have a Firecontrol controller attached to those limit switches if that matters to you. :wink:
They’re great for reliably homing and calibrating my system! :nerd_face: :rofl:


I’m currently considering it. :crazy_face:

1 Like

Wha…WHAT??? Are you considering limit switches or running your table with other than FireControl?

If it IS the limit switches, you would have to burn the t-shirt that says “Kill the Limit…switches” :rofl:


I bet there are over 50 posts regarding CrossFire limit switch problems. I think they were only introduced to silence criticism. With that being said, I still like you and TomWS. Even though he uses many words that I must look up, I swear he uses a threausaus. :stuck_out_tongue_winking_eye:


He does, doesn’t he!? Of course I am no expert on words including phrases like “Roll tide.” So I have to look up some of your stuff, as well. :joy:


Your pics aren’t showing your torch compared to your table. Is the screen showing the torch off the table? If so then that is your problem…not the limit switches

The error photo was just to show they work

Power supply is the problem. Any idea if theres a fuse to replace or need to replace the whole thing?

There is an adjustment pod on the power supply but it is not unusual for them to need to be replaced. Obviously, if you are still covered by warranty contact langmuir.

If not, this is an acceptable power supply:
ALITOVE 36V 10A 360W Power Supply Switch Transformer Adapter AC 110V / 220V to DC 36V 10amp Universal Regulated Switching Converter for LED Strip Light CCTV Camera Security System