Inkscape svg problems (wrong size) when imported to fusion

How have you people overcome SVG problems with Inkscape? I do not think this is a problem with Inkscape but more with Fusion 360.

When I download an SVG file from the internet , open it in Fusion , It is the correct size, no scaling needed.
When I create an SVG file with Inkscape and import it into Fusion 360 I ALWAYS must scale the image to get the correct size

Am I missing a setting, or doing something wrong? Is there a work around?
I have seen many try this or try that posts, but has anybody actually overcome this

Thanks Tim

Are you saving it as SVG or one of the other variants (Inkscape SVG or compressed SVG)?

Also are you running the latest version of Inkscape? Unfortunately Inkscape defines things in PPI an has used 72, 90 and now 96 points per inch. The opening program (Fusion in this case) needs to match it’s assumed PPI with what Inkscape used.

Also you’ll get small variations as well if you define your lines with any thickness - inkscape’s measurement of an object includes the line width. But Fusion and Sheetcam don’t because they’re just tracing the line with a beam of plasma - there is no line thickness. There is a setting in Inkscape that tells it not to use the line width but I’ll have to dig it out.

I am saving as a “plain SVG”
I am using Inkscape 92.4

When I draw in Inkscape I currently use inches
In Fusion the units are either metric or standard.

I will keep playing around but I am still kind of lost why some SVG files are perfect but the ones I create in Inkscape need to be resized.
I will try to create a file using PPI

Thanks Tim

All measurements in Inkscape end up getting translated into PPI and the receiving program often uses that to translate into their native units. Have you changed your Inkscape setting for geometric bounding box? If not, try that - it will exclude the stroke width from sizing.

In Inkscape, Edit | Preferences — under Tools choose the radio button to use Geometric bounding box (this excludes stroke width from the size, making calculation, placement and sizing easier and correct to what you think you’re setting when you size an object).

BTW, the current version is 0.92.5 - they’re coming close to the release of 1.0 (it’s in beta if you want to try it :slight_smile: )

I saw last night the updated version I will give that a try…
I will also try your suggestions,

Okay I just got my first object to import correctly…
object 5x5 square

document properties:
custom size
same dimension as the square
hit resize page to drawing or selection
scale 96.00
uncheck page border

and it worked!!!

now to try it with a more complex object…


1 Like