Initial Torch Fire Working Intermittently

I have a Crossfire Pro with the Razorweld 45 CNC and I have just begun working with the machine. The torch is not always initially firing when the programs start running. I am using FireControl to run the unit. When the torch does operate and initially fire, it will run through the rest of the cut. I am just not getting the torch to work consistently. If I operate the torch by hand, it starts as it should. When the torch does not fire, it will not start with the manual torch fire button in the FireControl program either. I am receiving the error message that the torch is moving before the torch fires. I have set the pierce delay at .5 seconds and I have tried increasing it when the issue occurs. It still does nothing. If I walk away from it and come back to it another day, it seems to work a couple of times and then stops again. Has anyone else dealt with this issue, or have any suggestions as to what might be going on?

Intermittent issues are a pain in the ass. I would start by looking for:

  1. Bad connection somewhere in the torch fire circuit?
  2. Bad relay on Crossfire board?
  3. Insufficient air pressure?
  4. Wet air?
1 Like

When did you receive your Razorweld? How old is it?

As of right now, I know that I have air pressure and I am using a dessicant dryer for the air that is coming out. I also believe that the relay is working because I am hearing a slight click when the razorweld should be firing. I do not believe that the razorweld is responding though.

I just received the razorweld in March along with my crossfire pro.

When you hear the relay click inside of the Electronics Enclosure, do you hear air escaping from the plasma torch?

Based on your symptoms it seems like it could be a loose wire somewhere. Does your torch fire cable seem to have a good fit in the torch fire port?

Thanks for your help. I got to play with it some more this weekend. A buddy who has a crossfire and a razorweld had suggested that maybe my razorweld was sitting too close to the crossfire unit. I moved the razorweld as far away from the crossfire unit as I could. I cut out 4 different pieces off of two different programs with no trouble on Friday. I didn’t move anything, and I went out there to test the unit again today. Today, the unit had the issue of not firing again.

When the relay clicks inside of the electronics enclosure, there is no air escaping from the plasma torch when it has the non-firing issue.

The torch fire cable seems to be fitting in the torch fire port well. I have also tried wiggling the wires when the issue occurs, and I have not been able to get it to fire by moving them around.

Failed relay contact?

Open the box and remove and install the relay and make sure it is seated. If that don’t work then as “Cletus” said it could be a bad relay.