I'm going to beat you

I’m in the process of getting my crossfire up and going. The first sign of trouble has bared it’s face, the set screws attaching the Y axis lead screw worked lose.

Fixed that and then the X axis tossed it’s lead screw set screws to parts unknown.

End of first experience, need to go to Abba Bolt and buy a box of set screws…
Btw I COULDN’T get through the breakin before the screws left for parts unknown.

And please don’t tell me I didn’t tighten them enough, any tighter and I would have broke the head where the allen wrench connects.

The lead screws have a monster chamfer on each end, nearly a point, this doesn’t help the set screw problem.

Suggestion. Leave the leave the ends of the lead screws square with a .015 edge break, don’t set the screws in the threads, put a whistle stop flat on it. That is a flat that has a slight back taper, that pulls the lead screw in, one flat for motor end, 2 on the support end.

Better yet would be make compression type lead screw attach couplings.

My first experience with “Fire Control” hasn’t been the best either, if I leave the plot on I get a general protection fault and a stack dump. The software itself I’m finding very minimal, first impression, you should have stayed with the Mach products.

In case you are wondering if I should be so audacious to criticize the software, I spend my days programming 5 axis mills with Siemens NX, I know a smidgen about controls.

Fred, I look forward to your reply.

You are comparing a 2000$ machine to one that cost 100 000$
A lot of users have minor issues when setting up their crossfires but once dialed in it can be a very useful tool.


I agree it will be a useful tool and I understand cost.

However, the leadscrew issue isn’t excusable. Two small changes would solve the problem. Make the end of the coupler that goes around the leadscrew .75-1.0 longer and add a flat at each of the screw. Lock tighting the set screws might not be a bad thing either.

My fix is to tig weld an extension on each of the couplers.

The stack dump when the plot routine runs isn’t easy to overcome, as the table is no longer compatible with Mach products I’m not sure where I’ll end up.

Forget about those set screw couplers and buy some clamping couplers. I can’t believe they are still shipping tables with those set screw couplers.

1 Like

Just another viewpoint

My install of Firecontrol has been totally without problems since I installed it in February. No errors, dumps, blue screens. I’m also running the new beta that was just released and aside from some install issues that they quickly resolved it’s been running fine as well. I run it on a Lenovo laptop with just Firecontrol and Sheetcam on it. I occasionally run Firecontrol on my MacBook as well and have had no issues there either.

As for it’s functionality, it has pretty much everything I need. Scaling, patterning, single cut, restarting I’ve used it all. I can’t think of anything off the top of my head that I’ve wished it had. I like that it does what it does. But of course that’s me. YMMV.

Now the lead screw couplers, yeah that’s definitely somewhere they could redesign for less grief. Had a bit of an issue initially but sorted it out and 8 months later no problems. I do regularly check and tighten the set screws just in case.

1 Like

Would you have link to some?

First off, welcome to the group!!! I hope it will prove as useful to you as it has me. I have some experience with controls as well, I was a EE for the US Navy working on full motion (six DOF) flight simulators. I design in TurboCAD, post process in Sheetcam and prepare nested cuts with deepnest.io. I load job files into Firecontrol and have run simulated cuts without software issues although I do have the same coupler issue you are having. Langmuir is sending another lead screw & coupler but I have ordered a larger clamping coupler that I will use in place of the smaller set screw coupler. I had a 1/4" gap between the end of the lead screw and the stepper motor shaft too which I suspect contributed to the coupler problem. In any case I am looking forward to getting the kinks ironed out and cutting some steel!!! There are several post you can review that cover this same issue and offer some useful information. Good luck!

https://www.amazon.com/dp/B003XHEEJA?psc=1&ref=ppx_yo2_dt_b_product_details This is for a 3/8" lead screw. Some people have lead screws that have been turned down to 1/4"

These are the ones that many people have switched to. RULAND MANUFACTURING Rigid Shaft Coupling: 1/4 in Bore Dia., 1215 Lead Free Steel, 1 in Overall Lg - 2AMD1|CLX-4-4-F - Grainger

My Pro came with this style coupler, but it only uses two bolts. I have a set of these on standby, but mine haven’t been an issue yet. My lead screws are turned down to 1/4" on the coupler end, but it seems that varies with some tables.

I found a set on Amazon with 6.35 x 9.5mm bores 25mm od x 30mm long. $34 for a pair. They are 6061. Keep you posted on how it works.

The PC I used doesn’t have internet, hence no help files for fire control. Hopefully I can solve the stack dump issue and get the graphics plot working.

1 Like

I received the coupling, installed. Took the old coupling and drilled the .375 thru, aligned them with a gauge pin and tig welded them to the end of the thrust bearing fitting. Now I have extra long thrust bearing ends plus the coupling improvement.

The software stock dump appears to be opengl related, I used an old computer and my choice of graphics was limited. I found a nvidia card online and installed it but the stack dump is still with me. The software works fine as long as I leave the graphics turned off. I am still irritated that the software stack dumps. I use NX, Catia, Mastercam, Fusion cad programs, they might not work well without the opengl feature but DON’T stack dump.

Anyone out hook up a Miller Spectrum 625 (older machine, not Gucci but works great still) to remote trigger? From the circuit diagram there is a switch marked “trigger”, and I get continuity when I close the trigger. But…there’s a third wire marked “cup switch” I get continutity through it also. Anyuone wanta chime in?

The cup switch wire is connected to the switch wires as a safety, so if the cup is off the torch will not fire.

Thank you, I’ll splice into the trigger wires.

Update I loaded a new graphics drivers and the plot routine now works.

I wired the plasma yesterday, with a little luck I’ll set up and cut something tomorrow after work. :crossed_fingers:


Well guys, just when I thought the water was safe…

Anyone got a snip of a running program. Firecontrol barks when I try to load a program, says it’s Mach3 program. Is there any documentation for tape/program format?

I tried to download a sample project but it doesn’t like my login, apparently my forum login is not my project share login.

Firecontrol needs files that were post processed with the Firecontrol v1.6 post processor. If you have a Crossfire without the Z-axis, you must set the pierce height and cut height to zero in your CAM software.

Start here to understand the workflow Software Workflow | Langmuir Systems

All of the user guides can be found under the “support” tab on that page.

Send me a private message and I’ll try to help get you going.

1 Like

IT WORKS. A gentlemen called from Pennsylvania a few minutes ago and supplied the final missing pieces. A millennial or gen z’er software writer needs an as… I digress

Here’s what I now know.

The program has to start with (v1.6-fc); this some sort of cryptic code to piss off guys used mainstream CNC, it has something to do with the version of firecontrol and the post they want you to use.

The last line of code must be (PS100), this has something to do with capping the feed rate. I was advised to just set a value of 100, and it worked.

In between:

circles are standard Fanuc, absolute XY incremental IJ values, measured from the circle start to the center.

G0 is rapid - again standard Fanuc,
G1/G2/G3 interpolation, and they appear to be modal. I’l force my post to output linear and see if all is still happy.

I’m using a 3 axis post made in NX Postbuilder. I can get 99% vanilla output. I still need to do something with the Z, I cannot cause to not output Z, I can make them all be Z0.0, so a quick global replace in the ultraedit and walla ! I’m in business.

My machine is the entry level machine, no Z axis, this works with it.

Thanks again to the gentlemen from Pennsylvania, and I hope this helps some other guys. I’m in the El Cajon area of Southern Calif, if I can pay it forward by helping anyone message me.

PS. IT’s Friday, I tried the machine, have a lot of learning to do. The walls of my cuts aren’t real square. Probably a little fine tuning needed. Note to others not following the “certified post” route, the machine doesn’t care about Z, I left them in and the program runs fine.

I have to say it’s pretty cool. (After a couple growing pains, head/wall collisions & and a little red behind attitude). Thanks for being patient with me.

1 Like

Well here we go again.

I found in another thread the little Beelink PC, very cool machine. Cheap. I then I noticed Firecontrol had a new build, so after getting my little Beelink up and running I down loaded Version 21.1.3 and loaded it… C R A S H. The software come up for instant, displays a message then crashes. It crashes too fast for me read it.

I uninstalled 21.1.3 and reloaded 20.6.2. That comes up without error BUT there’s a green bar with the words “update available”. Guess what, I cannot load a cut program…

I’m offline with the plasma table, sooooo maybe that’s is why.

So my little Beelink is on the beach until I get this latest round of BS resolved. Kind of sounds like my patience is thin, good guess