IHS Fail & Intermittent THC issues

Once I have cut the same file a few times or leave my machine on for any length of time it starts to behave this way (See video)

I have tried:

  • Removed the L1 resistor
  • Added many Ferrite Chokes (7)
  • Using 20.6 FireControl
  • Rebooted the computer
  • Rebooted the table
  • The control box is not mounted to the frame
  • The laptop has no power cord attached
  • Different computer

Please watch the video and let me know your thoughts. Thank you.


It looks like you have some kind of Everlast there is it hooked up to divided voltage?

Have you cleaned your contacts in the z-axis for your initial height sense control?

I would focus some scrutiny to this area.

Are you running a USB extension cable?

Sometimes if you have a long USB cable you could have signal decay.

Does your z-axis travel up and down smoothly with the controls while not cutting?

Hello (and thank you for your response)

I am hooked up to RAW voltage right at the torch lead and the ground in the machine
I am going to clean up the Z-axis gear today (thank you)
The USB cable is just a long one, I have this setup this way because I had so much freezing up when the machine was close to the box. I can shorten this but the problem was worse when the laptop was closer to the table.

Sometimes the z-axis does stick when its trying to go down. (Could that be the issue? and how do I repair that?)


As I said on Facebook, the Z axis appears to be the issue here. The wheels that ride on the Z axis rods may need adjustment, but the rods themselves look pretty dirty and may be causing some of the problem.

On the back side of the Z-axis wheels is a nut that holds the bearing to an eccentric. There is a small flat on the bolt that sticks out. Hold that flat with a wrench and break the nut loose. You can turn the eccentric with the wrench on the flats. Adjust the play, so the wheels can turn, but there is no play in the carriage. Hold the eccentric in place with the wrench, while you tighten the nut.

@ds690 is absolutely correct with the procedure you should follow with your z-axis.

With your page up page down keys on your keyboard ( set your speed rate to 50 in per minute first) you should be able to move the z-axis up and down smoothly and freely every time.

Clean and calibrate until it does.

Get a flashlight and give it a very thorough visual inspection.
Look at the plastic guy nut make sure it’s not filled with gunk.
Make sure the rods are clean.
Make sure the bearings are clean.
Once everything is super clean then proceed with adjusting.

Please post back with a follow-up if it works out for you. if not still post back and we can get deeper.

1 Like

Have you tried lengthening your pierce delay.

Fire control sets the first pierce delay longer than the set delay used for the following cuts. I wonder if your longer cable is causing a delay in the signal?

@TinWhisperer and @ds690 make several great suggestions. Do you guys think this may be a pierce delay issue on the cuts following the first cut?

Also I noticed that your cable was a little tangled in locations you don’t have a ferrite choke. The windings in the cable can cause interference issues.

Is your laptop plugged into the wall or running on battery power? Sorry just re-read your post asked and answered… :grimacing:

Edit: after thinking about it more i think it’s likely an electrical connection issue or a binding issue as it appears the z axis doesn’t even initiate the IHS movement so it likely isn’t a pierce delay issue.

1 Like

It’s definitely a Z axis binding issue. It has nothing to do with electrical or software.

The Z axis binding is causing the carriage to stop and the lead screw to continue turning, opening the IHS switch. This satisfies the condition of the IHS loop in the code and then the Z axis raises until the switch closes and sets Z zero in that spot. The torch raises to what it thinks it pierce height and fires the torch. It waits for the delay and lowers to what it thinks is cut height, but is actually far above the metal. The torch stops firing after the pilot arc burns out and throws an “arc voltage” error. If the Z axis carriage was still stuck when the lead screw drove down to cut height, then the IHS switch is now open. If you try to run the program again, you get an “IHS fail” error, because the expected condition of the switch is “closed”.


Here is something that happened to me - not that this takes care of cleaning the axis or rods, but it certainly looked similar in some ways

How did you make out with this?

Did you have any success?

Hello, and thank you for checking in.

Here are the things I have done so far:

  • Replaced the ground wire
  • dismantled the entire z axis mechanism and put it in my ultrasonic cleaner with soap (lots of gunk removed)
  • polished the two z axis guide rails
  • tightened up and leveled the z axis rolling mechanism.
  • 3D printed a splash guard for under the z axis mechanism and installed it
  • removed the grounds from all devices (water pump for table, laptop, and the control box itself
  • got a shorter usb cable and put ferrite chokes near both ends

I have yet to test the table fully since I have done this, but it seems as if I am in the right direction.

I need to cut something this week so I’ll update the thread.

Thanks again.