I know a known issue

Ok, I know this issue has popped up on here a few times, and I’ve read quite a few. Lets see if I missed something. I’m using a PrimeCut 60, still the Original USB cable, it has extra chokes on it. The issue only started when I replaced my computer when my laptop died. I replaced it with a desktop. I know the Desktop works perfectly, I can stress test it all day long, but as soon as I go to cut, the Crossfire disconnects. I can even do dry runs all day long, no issues. I had this issue with it originally, with another desktop, then found it worked fine with my laptop, so I started using it. Now that I don’t have a laptop and hooked it up to another desktop the issue has reappeared. I thought the issue might be grounding issues because I read here on the forums it has been mentioned that grounds might cause the issue. I have isolated the ground from the Desktop and the table. The Desktop has its own ground straight to the grounding rod. I also have put rubber washers between the control box and the table to try and electrical isolate it, because I’ve read somewhere on here (I think) there should be no conductivity between the control box and the table. Can anyone think of anything else…still waiting for a e-mail from Langmuir…I wish I could call or they call me. Hate trying to diagnose something by e-mail.

Accidentally put this in the regular Crossfire Trouble Shooting topic.

Are you able to put the desktop on a completely different circuit breaker from the table, not just different outlets but circuits to your main breaker box.

I use a laptop unplugged while cutting and a longer USB cable I bought separately. I have a Primeweld Cut60 as well. I also have 2x 120V 30amp circuit runs plus a single 240V which helps to distribute loads for everything in my small shop.

Put your desktop as far away as possible and get a longer USB cable.

1 Like

Yes, I just went and tried it on a completely different circuit breaker and it still disconnects after it starts its first cut.

You have to eliminate the earth ground not different circuit.

You can run a completely different earth ground or use a ground isolating plug.

Pretty much your plasma and computer can’t share the same earth ground


I have tried eliminating the ground, I even running a new ground to the outlet the desktop is on, so it has it’s own dedicated ground…strait to a grounding rod. So far no luck…only thing I haven’t tried is a new shielded usb cable, still using the one Langmuir sent.

If it is a separate ground rod your USB plug could be touching the control box

1 Like

Is that grounding rod the same one the electrical panel is connected to? If so it’s connected to the same ground. Have you checked for continuity between the table frame and the USB shell when it’s plugged into the computer?


no, it’s not on the same as the electrical panel

1 Like

how close is the cutter to the control box and computer?

also, is you look at the USB port on the control box, is the metal shielding around the usb port touching the enclosure at any point? i’ve read some has issues with disconnecting

just checked the metal shielding isn’t touching. (Just checked) but I know my control box isn’t isolated from the table as I once thought. I just put a meter on the screw of the box and the table and got a reading on the meter. Not sure where yet, because when I built it, I put rubber washers inside and between the box to try to isolate it.

Edit: guess we were typing at the same time :grinning:

Don’t overlook the remark about the USB port touching the controller case. Mine had hard interference. I loosened the board and put a piece of folded rubber between the case and the board to act as a spacer and to create a gap.

I have PW60 and had a bit different issue. FCtrl would freeze, but the program usually kept running. I implemented every countermeasure I read on this forum and it still happened 75% of the cuts.

In the end, a different laptop solved my problem. I suspect original laptop not having a dedicated graphics card was the root cause.

Anyway, I type this in order to say, you may be bumping up against difference in the computer hardware and no amount of changes you make on the table, electrical circuits, etc may solve your issue. I’d try to borrow another laptop and see if it goes away again.

1 Like

Have you checked for continuity between the table frame and the USB shell when it’s plugged into the computer?

Yes, just checked, no continuity between the table and the usb shell. Langmuir had me check that too. Langmuir is sending out set of ferrite chokes and a USB isolator to install. Hopefully that fixes it.

1 Like

I hope so, but doubt the isolator will do anything if there is no continuity now. When you check it you have it plugged into the computer right? Also was there water in the table when you checked it?

Yes, I checked it with the usb plugged in, and water in the table. I’m not hopefull for the isolator working either. Not sure why only desktop is being effected. I used my dad’s laptop to do a cut today, and his worked fine. So right now score 2 Laptops worked, 2 desktops Failed. Even went as far as removing the grounding prong on the desktop just test. Isolated outlet to its own grounding rod (had it set aside to run a ground for powder coating). Tested the outlets with a outlet tester, just for added fun. Not really wanting to add cost of buying another laptop at the moment.

are you isolating the monitor as well?


Have you tried just removing the control box from the frame and cutting? Do you have any pictures of your set up?

Yes, the monitor is on the same outlet I isolated with the desktop…though I never even considered that prior to you asking.

1 Like

That’s my next thing I was thinking…I’ll give that a try, and I’ll take some pictures.

1 Like

Any luck as far as progress?

1 Like