I just can’t make this work

I just can’t seem to make this work. I have pretty much tried everything. Going to try putting the hand torch on the machine tomorrow.

Today I reversed the y-axis lead screw because there are several scratches on the lead screw that I haven’t noticed until now (contacted Langmuir and awaiting a response).

I have tried everything I can think of, with the help of many members.

Today I made a cut and the machine cut out two small cuts and then stopped. It kept moving but no arc. My previous (2 minutes earlier) it cut the entire project - except for a small cutout on a letter A. This is just garbage.

I should be able to plug and play for the most part. I have struggled with this since day one.

If it were just cut quality I would chalk it up to the welder and consumables. Which is another issue in itself.

I can’t imagine that because I have an Everlast that is the reason for all of this. I have talked to others that aren’t experiencing any of these issues.

Yesterday I cut the same exact file and there were no off cuts on it. Other than it didn’t cut a piece of the letter A. How does one file present so many issues with mechanical cutting?

Thank you to so many folks on here, especially Bill P, who have tirelessly helped me over the phone and through email trying to sort this out.

I’m frustrated and at my wits end. I have wasted so much metal with this. I’m really not sure what to do at this point.

This was suppose to be exciting and fun and now I just feel like the joy has been sucked out of me.

Sorry for the rant.

1 Like

If your lead ins at too big and pierce clearance is too big it may not cut out smaller holes I think. Keep trying. There are lots of details on the computer side of things that can mess things up.my everlast works great too btw. I betcha there are stupid little details that could just be screwing with yA. I dunno man… good luck!

do you have the machine or hand torch connected to your table? also, did you wire to the cnc plug to the back of your machine?

my settings on the software side are good to go. my lead-ins have been shortened and the pierce clearance is good. in the project I did the other day there were two A’s, one cut fine, the other didn’t cut the little triangle out.

it’s just frustrating at times.

thanks for the response,


I’m assuming your clamping the ground directly to the metal you are cutting? Using the small shim? Gantry level? Material not warped?

All problems I had in the beginning… warped material being the worst… Thats why I added a Z axis and torch height control.

What gauge metal you cutting? For working out the bugs, I wouldn’t use anything smaller than 14g, and you should only need about 30-35 amps to cut that with a .9 tip. feedrate between 90 and 150. small shim for clearance. set the height and run it around the metal with the torch off before cutting, watch what happens to the gap. if it changes significantly bigger or smaller… It will affect your cut.

1 Like

Are you using a razor weld plasma cutter?

He’s using an everlast 60s

Thanks Dicky. All the things you asked I’m doing. I will look at the metal more closely with my next test cut to see if it’s bowed or uneven. But would that explain it not cutting out part of an A that it already cut out the outline?

Does it stop firing during the cut? if so, are you by chance using an extension cord between the cutter and the power outlet? if so, that could be your problem.

1 Like

Not necessarily an extension cord. But sort of. I am using a cord I made that I use for my welder that has a receptacle on one end and the same plug on the other.

And yes it stops firing but keeps moving.

have you tried plugging the cutter straight to the outlet to rule out the extension?

I had my cutter (primeweld cut60) on an extension and after a few cuts it would “misfire”. after i plugged the cutter to the outlet, no more misfires.

Air supply maybe? Sometimes my plasma cutter will cut out if the pressure drops below what the machine is wanting. It has an internal regulator. Or before I got a drier… heavy moisture would cause it not to cut through in sections. Just a spitball since you have apparently looked at almost everything else

Fixed! For now. Still waiting on a response from Langmuir about my lead screw being “chewed up”.

As far as the torch cutting out - it appears one of the leads I fashioned came undone. I am running a machine torch and it has a wire coming out of the end that plugs into the machine with two exposed wires coming off of it.

I never used the supplied plug that plugs into the cnc port on the back of the machine. I tried when I originally got the machine but it didn’t work. Maybe my soldering job wasn’t good enough. In either case I connected the two wires coming off the torch plug to the torch cable from the Langmuir box/controller. That worked.

Today as I was going through my mental checklist I decided (with help from Bill P) to hook the hand torch to the table. I had to undo the wire going to the controller and the machine torch. While I was doing this one of the wires just fell out of the barrel connector.

I had these wires wrapped in electrical tape and I was positive the barrel connector was enough to hold the wires.

I must’ve been in a hurry when I connected these and it makes sense that most of my beginning cuts were pretty decent. But I’m almost positive the problem with most of my issues are because the circuitry for the torch firing was being interrupted during the operation.

I still believe the lead screw is causing some issue so I need to get some help from Langmuir.

Other than that, I ran three cuts, small ones and other than dross and some minor pierce issues, they came out pretty good. I say pretty good because my consumables are in bad shape, the nozzle that is.

Thanks again for all the replies, patience and help.




I had some very similar frustrations when I started. The whole problem was the USB cable between the computer and the plasma table was laying next to the plasma torch cable. It would misfire constantly and act confused.

Make sure all the cables are separated as much as possible. Especially the one going to your computer. EMI can screw things up big time.

I have my laptop on my welding table away from the plasma machine and the cnc table. I did order a longer cable, but doubt that is causing issues.

Not sure what EMI I would get that wouldn’t be in any other setup. I have an extension cord on the ground so that the controller can be hooked into that. the torch goes to the plasma machine, which is on a rolling cart off the ground. the USB cable goes to a MacBook. and the cnc plug goes to the plasma machine.

I should be getting the Hypertherm on Monday, Saturday if I’m lucky and we will go from there.