I am getting a pierce then nothing

When I run the program, my cutter will pierce then pause the program. When I click resume, the cutter will follow the pattern and make the next pierce then pause again.

Is there any kind of pop-up message in fire control?

It feels like a short Pierce delay but need more information.

Your pierce delayed needs to be at least .5 in your post to work with the timing on your langmuir.

is your torch set to 2T or 4T

I am in the 2T setting. This time I did get a pop up message. I have attached the screen shot.

you have to go into your post processor program and start increasing your pierce delay…some plasma units required a longer pierce delay.

I saw his video on Facebook. I don’t think its pierce delay. The torch is firing and either not transferring to the cutting arc or burning out because the delay is too long. Maybe the plunge rate is too low or it could be interference from his Cut60 or grounding issue with the computer/laptop charger.

I ran the torch test. It said I am not getting voltage. I am re-soldering the cnc connector.

Unplug your laptop charger. My Everlast does weird stuff like that with the charger plugged in…

if you’re using the cut60, connect it to RAW voltage inside the cutter NOT divided voltage via cnc port. There’s been issues with running it divided voltage for some with new cut60 cutters… RAW seems to work better.

I will try that.
I was able to cut with the THC off

The raw voltage solved my issue. Thank you all for your help. I greatly appreciate it.


Which is correct,2T or 4T

2T is correct.

1 Like