Hypertherm45 XP Wiring CNC Port / Torch Failing to Fire

I would like to use the CNC port that came with the 45XP instead of tapping into the internal wiring. We’ve attempted to splice together the wiring that came with the table and the CNC cable that came with the Hypertherm. I’ve read several posts, but now I’m more confused. One post mentioned using a remote trigger pendant that you would tap into with the wiring from the table. Has anyone successfully wired up to a Hypertherm CNC port by utilizing the included CNC cable? If so, I’d love some help with getting us past this last step that’s preventing us from finally using the table to cut. Thanks in advance!

Hi Trey,

Do you have the machine torch with your Hypertherm? Unfortunately the CPC port on your cutter does not work unless a machine torch is installed.

Yes, I failed to mention that we are using the machine torch with this setup and not the hand torch.

Which pins on the CPC port are you connecting the torch fire cable to?

If you have the pins correct, and you have installed the Crossfire V1.1 configuration and the motion control plugin, then it should fire.

If not, then there could be a connection issue somewhere that needs to be fixed. We can work with you on that. Your electronics were fully tested including torch firing, so its unlikely but possible that the issue is something with your electronics.

Use wire #3&4 on the Cpc plug on the cutter and wire that to the crossfire plug that should fire the torch

We have taken all steps in troubleshooting the firing issue including the v1.1 and motion control plugin and we even reduced the CNC cable from the Hypertherm to two pins(3 & 4) and yet it is still failing to fire the machine torch. We can rig the machine torch to fire(zip tied), but then it cuts into material where the CNC table should have stopped the torch. So, we have a Hypertherm 45 with a machine torch and a CNC port with pins 3 & 4 connected to the CNC tables’ leads, yet it still fails to fire. We’re not sure what else to try at this point…

Hi Trey,

When you press F5 to command the torch to fire, do you get a blinking yellow bar above the torch on/off button in Mach3?

If you get the blinking light, then turn off power to the machine disconnect the power cable. Next, remove the cover from the electronics enclosure. Plug in the USB cable from your computer if not already connected.

In the picture below you will see two small red arrows pointing to pins on the motion control board. When the torch is commanded to fire, you should measure between 4 and 5 volts when the leads from your multi-meter are probing those pins. If you aren’t seeing any voltage when F5 is pressed, then please let us know.

OP mentions zip tying the trigger on his machine torch. Well if it’s a machine torch there is no trigger, which is why it won’t fire. You can switch pin 6 to 8 in the hand torch if that’s what you have to trick the hypertherm into thinking it is a machine torch.


Hi. I have a hypertherm 45XP with machine torch and cpc port. I have attempted to connect ports 3 and 4 in the cpc port to the two wires coming from the electronics enclosure. The torch is not firing. I followed your instructions above and saw 3.96VDC across the two pins you indicated. Sooooo…now what?
Thanks for your help,

Hi. I have a hypertherm 45XP with machine torch and cpc port. I have attempted to connect ports 3 and 4 in the cpc port to the two wires coming from the electronics enclosure. The torch is not firing. I followed your instructions above and saw 3.96VDC across the two pins you indicated. Sooooo…now what?
Thanks for your help,

Is Mach3 working correctly otherwise? Is it able to run the Langmuir break-in program? Did you turn the Crossfire on first, then load I Mach 3 and then the torch? (Torch power order doesn’t really matter but you want the Crossfire on before you start Mach 3.

Hi, I don’t think I was real meticulous about how I fired stuff up, but I’ll try it in that order. Regarding the post above, while I had the electronics enclosure open, I put a voltmeter on the pig tail wires on the end of the torch fire cable. I fired the torch in Mach 5 and didnt see ANY voltage out of the torch fire cable. So then I figured maybe the cable is bad and unplugged the leads going into the torch fire port. Fired torch again, no voltage. Something seems dead here…

I just followed your steps. Crossfire off. PC on, but Mach 3 closed. Torch off. Turned on crossfire. Opened Mach 3. could move torch around anywhere. Pressed torch fire and the voltmeter attached to the two wires coming from the circuit boards, going out to the torch firing port showed NO VOLTAGE.

Sounds like a problem for Support then. I made my own control cable for the Hypertherm & Crossfire because I wanted some more distance between the cutter & the table. Grabbed a 15 foot power cable using the same jack that’s on the Crossfire (2.5mm?). Clipped the male end off and wired that to the CPC Port plug I made. It all worked fine and 3 & 4 are what I recall were correct.

That’s whats driving me bananas. I have all the components to build the CPC port plug on their way but jury rigged some stuff today just to try to make it go. Did you ever measure voltage coming out of the torch firing port on your set up when you use Mach 3 to fire the torch? I’d be curious to see what you’re seeing…

Nope, I just checked for continuity on my cable and then just plugged it all in. Worked first time.

This may not apply to you but when I first got mine going I stripped the wire back and crimped some ends on and just slid them on to the pins on the back of my plasma cutter and couldn’t get any continuity with my meter so I checked the ends by their selves and found out that the wire actually had 2 layers of insulation on them, and I only stripped off the color insulation and didn’t see the clear insulation with my old eyes until I put on my glasses. haha
Don’t know if that was a shielded wire or what but once I stripped off all of the insulation it has worked like a charm.

Good luck


You shouldn’t see any voltage out of those two wires, but rather continuity. I recommend walking through this troubleshooting guide: Torch Not Firing - Troubleshooting Guide

That will tell you exactly what the issue is and support@langmuirsystems.com will get you whatever you need to get it repaired.

Ok, I’m now even more confused. I’m getting continuity out of the torch firing port from the communications enclosure AT ALL TIMES. I just verified this by doing the following:
No PC connected. Voltmeter attached to two wires stripped out of torch firing cable. Communications enclosure powered off. And getting continuity. Turn Communications enclosure on. Still getting continuity. This makes sense to me as the Hypertherm 45XP was throwing the 0-50-0 error code indicating it was getting a torch fire signal upon powering up. I’ve verified the software settings Daniel indicated in his troubleshooting guide. What else could it be?