Hypertherm 45xp torch won’t fire

Well I have a brand new Hypertherm 45xp hooked up to the crossfire xr and torch won’t fire, I pulled the machine torch off the table and can’t get it to fire by hand either, any ideas before I call Hypertherm, no air or arc coming out of the torch,

Thanks guys

Is the switch on the torch turned on?

Yes the switch is on and the yellow light comes on the plasma when your turn the torch off, and no errors on the plamsa

Are you using the langmuir CPC port wiring adapter to hookup the hypertherm?

Do you have a hand torch and a machine torch?

Which yellow light comes on.

That machine should have a green light on it when it’s ready to go.

Yellow LED typically means a fault.



Page 163 of the service manual starts to go over the yellow LED fault indicators.

What mode of operation do you have it set for and at what amperage?

What air pressure are you sending to the hypertherm?

1 Like

Tin, you have a lot more patience than I do, I would be yelling already turn the air supply on or check air pressure…

1 Like

Now you know why @TinWhisperer gets paid so much! It certainly isn’t for his looks!

3 Likes

Machine torch only, COC cable from Langmuir installed Mac 120 psi straight off the compressor, what I meant about the yellow light is that it comes on when you turn off the switch on the torch indicating that the switch is working. And yellow light turns off when you turn the torch on, it’s on cut mode also, only thing I didn’t try yet is to unplug the Cpc cable and see if it fires

Could you possibly have the two barrel connectors mixed up off your CPC connection?

What do you mean by straight off the compressor.

There should be particulate, oil and water separating equipment between the compressor and the hypertherm

K that’s doesn’t keep it from firing :man_facepalming:t2:

My Cpc cable has one end that goes to the div and other than is a screw on type that goes to box off the table

And with your torch and a safe location , if you just jump out the end of the torch on/off cable it doesn’t fire your hypertherm?

Cuz if you hear no relay click maybe the relay is not seated correctly. The relay inside the langmuir electronics enclosure.

The only click I hear is from the thc box, I get 0 arc or air off the torch

I don’t think anyone suggested that running unconditioned air into your hypertherm would cause it not to fire.

Try to jump out the two pins on the end of that screw type connector and have your torch a safe position to see if it fires.

Sorry I’m just still working on setting everything, I have everything to do it right with dryers and what not, just trying to see something work for the 12k I just spent ya know, so last night I just hooked up the air hose to try to cut a scrap piece

The work lead is connected directly to the piece of scrap metal?

I had the same issue when I hooked up my Hypotherm 45xp. I checked my air tank pressure gauge, and it was at 120psi but the gauge from the dryer/water separator was at 65. Once I cranked up this pressure it worked fine.

1 Like

I had to send mine back after the pin wouldn’t engage when I screwed in my consumables, luckily it was under warranty