How to have a DXF file work in Firecontrol

OK, bare with me, i haven’t had the time needed to be proficient at sheetcam, so i had the gentleman at “ready to cut” take my picture and turn it into an DXF file , and i finally got it into firecontrol but i keep getting the error " no speed program"? To get in firecontrol, i moved the DXF file into sheetcam and did nothing to it besides hit the post processer tab. I thank you guys for the file share files, the ONLY files i can cut are the files that have been post? for firecontrol ? I did find out that “ready to cut” dosen’t mean its ready to cut on my crossfire with fire control. I can get “your” files to show up in sheetcam but I’m lost from there. So I’m trying to figure out how to make any DXF file to cut on my table, the files that have been made for firecontrol from the file sharing work just dandy! Thank;s for helping this old man, lol

well…we will be glad to help…
first here is a link to Youtube videos to help learn some of the basics


Fire Control only reads TAP files or Gcode.
Gcode and TAP files are what you processed or post processed files made from files like DXF and SVG.
so far only Sheetcam and Fusion360 have the ability to process files for the Langmuir tables.
if you have Sheetcam do you have the full purchased version or only trial version…either way you will need to make sure you have the postprocess file from Langmuir installed in Sheetcam or Fusion.

watch the videos…do some searching on youtube for sheetcam and you will pick it up quickly


Do you have any “tools” set up in Sheetcam?

Import the DXF by going to “File” and “Import Drawing”. Then click on the top icon in the “operations” box on the lower left of the screen. This will open a “Jet Cutting” window. Select “outside offset” , select the layer your drawing is on and select a tool to cut with. Click on OK and the screen should show cut paths in Green with start points, lead ins and lead outs. Now you can click on the post process button and get a .tap file that Firecontrol can use.


Thanks for this info! Saving this for later so I can get my popcorn and watch!

what I did was watch the vids on a laptop while running sheetcam on another PC…that way I could play and watch…


Why didn’t you run it on one of your other monitors?


Hi, it was before xmas but i did get the dxf file processed into a tap file, It does load into firecontrol but l get the " no speed found" notice, i have gone back into sheetcam and checked, the ipm is there. Also i do have the license for sheetcam but i’m not sure about the ? post process file? you mention. All i can say for sure is when i moved the dxf to sheetcam and i did nothing to it excecpt hit the post button and it processed just fine, someone was asking if i have a tool setup, yes i went all though the op’s, so i have a tool set. Like i’m saying the tap file now shows up in firecontrol just won’t cut. thank you

Yes I have that part down, I like sheet cam just wish i had started a long time ago, I certainly only know some basics.

I do not think you have installed the postprocessor for firecontrol into sheetcam

this is found on the Langmuire site at Downloads | Langmuir Systems

you also need to read this page to install it and how to processs a file

why it says not speed found is that your sheetcam is not processing a file to the language that Firecontrol reads…

If this is a recent install of Sheetcam, go to Options, then Machine Options and click on the Post processor tab at the top of the Machine Options window. Go down to the Post Processor section and click on the drop down menu. Select Firecontrol v1.6 as the post processor and click on OK.

1 Like

copy that, thank you very much, I know i downloaded sheetcam post but i may have done it wrong, i will check into it. thanks

thank you, i will check that also!

here is a hint…
when you want to reply to someone and get their attention…you type the @ symbol and right after the symbol start the persons name…just like I did for your name…

that way you can type one PM and put their name at the start of the sentence…and it tags them

good luck…keep us posted

1 Like

@ds690 , Ok, I think the post is in the right folder now, it does show up in the machine options. I will try it today. thanks John

1 Like

@toolboy Well I have both latest downloads for the newer firecontrol and sheetcam post processer and it does show up in the right box in sheetcam and when i run the processer, it works just fine or so it says! But still when i try to cut it, still comes up “no program speed found.” I did import one of the dxf files from file share to sheetcamm and i went though the motions and it said it processed with no problems., but still the same message when i try to cut it in firecontrol, no progrm speed? thx, John

here is a process…see if this is what you are doing

you import a drawing into sheetcam and it open…example
you then click “operation” and select “Plasma cut”
and this pops up
this is where you select which tool you want to use for the metal thickness…once all this is proper then you click OK…then you can post process.
here is an example of a tool created

does this look familiar to you?

Upload the post processed file here, so I can see what is being output when you post process. DXF files are not what Firecontrol uses. The post processed file from Sheetcam will end with .tap

Even if you did something wrong, Sheetcam will still post process and output a .tap file. It just won’t have any G-code in it.

@toolboy,Yes familiar, I have a couple of tool sets that cover different gauges of metal and the only thing different my lead in is set at Arc with .15? lead out is none, lead in type is set at normal. Like i mentioned the 2 i have tried does post process in sheetcam as a tap.

@ds690 got that part, i can get them into sheetcam and they process as a .tap Just get the “no program speed found” notice I’ll try to load my tap file into firecontrol that started out as a picture. thx, John

What I mean is Sheetcam will process anything into a .tap. Even if you don’t import a drawing, it will create a .tap file if you hit the post process button. I hit the post process button on a blank screen and got a .tap file with the following contents:

G90 G94
G20 (Units: Inches)
M5 M30

That first line is the post processor version, in this case v1.6-sc(Sheetcam). The last line (PS0) is the program speed, in this case it is 0(zero).

You can upload your .tap file here by clicking on this button