Homing Limit Switches X axis going wrong way (SOLVED)

Hi, Im currently adding Limit Switches to our Crossfire Pro and everything seems good expect for when I try to Home.

The Y axis operates correctly but the X axis is running the wrong way, I have the limit switch by the X axis stepper motor so its driving to drive left to right vs right to left and into the Switch.

As far as I can tell everything is hooked up right and the table works fine without the switches, Im scratching my head and hoping somebody can help.

Did you reset the defaults? Failure to do so will result in homing the wrong direction.

3 Likes

I had done that, but something must not have clicked. I just did it again and it appears to be working now so thanks.

2 Likes

I had a similar response when I set up my switches. Not really sure; but, I think FireControl needs to fully restart and form a new relationship with firmware changes of the enclosure. It may even require a restart of both.

Glad you got it to work. Welcome to the community. I will mark this as “solved.”

1 Like