Homing failed with limit switches

Good day,

I recently finished assembling my crossfire pro with limit switches. I was able to home the machine to do the break-in program as well as do my first simple test cut.

Trying to home the machine for a second test cut, the homing always fails with the message “Cycle failed to clear limit switch when pulling off.”

The limit switch is well positioned as good as it can be, if I jog the head 1/16" away manually, I hear the switch clock closed again. I can repeat the process over and over again with the same results.

I think I have a finicky switch. Can I increase the pull off distance somewhere to something greater than the 4mm default?

Firmwre is all up-to-date.


I might be remembering the warning language I received incorrectly, but it sounds like what happened when I tried to home when one or both axes were at 0 limit. If so, you just need to move both to some nonzero location and try machine home again.

Thanks, I know exactly what you mean but no, it’t not that error. I jog the head way away from limit switches and the problems happens after it moves back to trigger the switches and pulls away. The head doesn’t move away far enough form the X limit switch.

Gotcha. Is it possible that the switch assembly isn’t firmly locked into place and the whole thing is displacing when hit and then following the head back when it pulls off?

No, it’s solid… I just need more than 4mm to get it to click again and no trigger an error. But I don’w know if or where I can change that setting.

It’s weird to me why the head doesn’t pull off UNTIL the switch clicks back closed as opposed to a fixed value that triggers an error…

Did you find a fix for this issue?

Has anyone figured out how to change the distance the machine pulls away from the limit switch? Both axis are wired correctly. Support just sent me links to threads with no real answers. If I wanted to waste $100, I would have just taped a $100 bill to the table & not dealt with the aggravation of spending so much time adjusting the position of the switches with the same result.

Disconnect them. There is no reason to even have them except maybe indexing a giant sign more significant than the table. There are fifty threads and 100 posts on these switches that all say the same thing. These limit switches were an attempt to quiet the complainers several years ago. Sorry about your $100. Drive the torch over to where you want to start and start cutting.

1 Like

Thank you. I saw most of the posts, including your post about not using and thought I wish I would have know about issues before buying. I worked for a company that manufactured limit switches and thought these would have served more of a safety purpose to keep from damaging the table, e.g. limit switch at end of jetway that cuts power when black wheel touches plane so it doesn’t push plane at gate. Thanks again

1 Like

Welcome Kirk.

Not to digress with @Bigdaddy2166, but I’ve had Limit Switches installed for over a year with minimal issues. What exactly is going on? When you say “to change the distance the machine pulls away”, are you talking about the initial retract after the switch is triggered? Or are you looking for how far the axis (X or Y) can travel “after” triggering the limit switch?

In our case, the switches preform as expected, preventing gantry crashes in both the X and Y axis. (Yes, I know this can be prevented by paying attention, but some operators are more alert than others!)

1 Like

I agree with you. My problem was that I was shooting coolant from a garden hose sprayer on the switches.
By adding the wash-down system, I never thought about the switches. My metrols work, but If it weren’t for my spraying, the original would probably still work.

1 Like

Initial retract after switch is triggered. Y-axis is fine, x is the one causing alarm/error.